summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-06-23 10:38:42 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-06-23 13:23:21 +0200
commita254987a6030b4fefdc5989c960772dddd866faf (patch)
tree35fce4a7cb0ca332d9d88a5770a0315da4e53e0a /dev-ml/macaque
parenteclass/myspell-r2.eclass: Fix typo in comment. (diff)
downloadgentoo-a254987a6030b4fefdc5989c960772dddd866faf.tar.gz
gentoo-a254987a6030b4fefdc5989c960772dddd866faf.tar.bz2
gentoo-a254987a6030b4fefdc5989c960772dddd866faf.zip
Revert "dev-ml/*: Remove := slot ops from || deps, #586304"
This reverts commit 2d4ac687fbf44588f764697c9dcb2b960a18d51b. This commit is wrong in several aspects: - Such changes should come with a revbump - Removing := deps causes packages not to be rebuilt on upgrades, causing barely understandable build failures when upgrading, later on. Thanks to this commit, people that have installed those packages will likely experience those failures with the upcoming ocaml 4.03 unmask. - This is a non maintainer commit where no discussion at all happened with the maintainers during the 3 days between bug report and mass commit. Such discussion could have prevented the above mentioned breakage. Proper fix is to drop the backward compatibility part of the || () dep. This fix was slowly moving forward whenever possible and noticed. Main blocker for this is bug #463018 which requires taking extra care for not breaking the stable tree nor needlessly preventing future stabilization of packages.
Diffstat (limited to 'dev-ml/macaque')
-rw-r--r--dev-ml/macaque/macaque-0.7.2.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-ml/macaque/macaque-0.7.2.ebuild b/dev-ml/macaque/macaque-0.7.2.ebuild
index 25a79790f59..9f245daae49 100644
--- a/dev-ml/macaque/macaque-0.7.2.ebuild
+++ b/dev-ml/macaque/macaque-0.7.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -16,6 +16,6 @@ KEYWORDS="~amd64"
IUSE=""
DEPEND=">=dev-ml/pgocaml-2.1:=
- || ( dev-ml/camlp4 <dev-lang/ocaml-4.02.0 )"
+ || ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )"
RDEPEND="${DEPEND}"
DOCS=( Changelog README.md )