summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-05-05 12:05:59 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-05-06 18:17:20 +0200
commit2e744a16407bede99f41c618baeaaae288e0ba29 (patch)
treeef56f86a541ef51919fe48d100ee02b1a98b26eb /dev-ml/ocaml-conduit
parentapp-office/libreoffice: [QA] Convert absolute symlink to relative. (diff)
downloadgentoo-2e744a16407bede99f41c618baeaaae288e0ba29.tar.gz
gentoo-2e744a16407bede99f41c618baeaaae288e0ba29.tar.bz2
gentoo-2e744a16407bede99f41c618baeaaae288e0ba29.zip
dev-ml/ocaml-conduit: Bump to 0.15.3
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ml/ocaml-conduit')
-rw-r--r--dev-ml/ocaml-conduit/Manifest1
-rw-r--r--dev-ml/ocaml-conduit/ocaml-conduit-0.15.3.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-ml/ocaml-conduit/Manifest b/dev-ml/ocaml-conduit/Manifest
index a704e9956d11..2fa87853e3cd 100644
--- a/dev-ml/ocaml-conduit/Manifest
+++ b/dev-ml/ocaml-conduit/Manifest
@@ -1,2 +1,3 @@
DIST ocaml-conduit-0.14.5.tar.gz 38471 SHA256 00aba333c05866bb712f7890c6f9fd457b85cf592d28adc6636413032683f86f SHA512 c2de6518588e3555cd40dfc6c1ce6d809dc570ddb6a07fb8ccce1797469e9c28ea1a633d4a1b360bf15cdb95e6231ecb0be8bd44e4654baa5268f09519096b52 WHIRLPOOL 5e052d7b9d34d76662496739a6934bf64c1930ca64b2160aa8cbefe0237bd0bb3438a187c3dd05d841b7b475325afcb32bb6fb20e0b61b885c16f4b0b3259aea
DIST ocaml-conduit-0.15.0.tar.gz 38617 SHA256 fa8c812c1e87cc59e7f6f8fd6d716014aadeda9853e5c6feacd5ecdd1fec5815 SHA512 112a09df2edc7bb0f174f19ad7d826aaf8116cce86e66182a27b4edadcffeee632d7e5cad489e9e797147b94ec81b1f1d122e9e30e384c0c84847875f9bed096 WHIRLPOOL 80bc7aa47df74c4a17c60e26bc9fd34a2167682cc63821918b33e03429f35710882a244aed61578d1e8ac7a34f67d3ba65e40754e066109b433a50868e73c243
+DIST ocaml-conduit-0.15.3.tar.gz 38921 SHA256 6760c9fed6b1c5360d74b4cd6fafbd78e1736c08d3024ed9ecb79b29ad3456db SHA512 0666ed22a93351dc8381de3eaafcf019336f9d62e6b7ed7c0bcd7e202ecfb54ede8ed999023a0ed712da6406cee872965b22c77982ed65897b2e0abfadd0a07c WHIRLPOOL e754553c08fe31be337b8f1aaf504a5319af66aea9f897b411a6ca4d8efd4a5c1ac9488cbe7ca091f7c87ce4171e3725f701a9f8359d04dfd6c6cca350a1a611
diff --git a/dev-ml/ocaml-conduit/ocaml-conduit-0.15.3.ebuild b/dev-ml/ocaml-conduit/ocaml-conduit-0.15.3.ebuild
new file mode 100644
index 000000000000..b6dd676dd490
--- /dev/null
+++ b/dev-ml/ocaml-conduit/ocaml-conduit-0.15.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib eutils
+
+DESCRIPTION="Dereference URIs into communication channels for Async or Lwt"
+HOMEPAGE="https://github.com/mirage/ocaml-conduit"
+SRC_URI="https://github.com/mirage/ocaml-conduit/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-lang/ocaml:=
+ dev-ml/sexplib:=
+ dev-ml/stringext:=
+ dev-ml/ocaml-uri:=
+ dev-ml/logs:=
+ dev-ml/ocaml-cstruct:=
+ dev-ml/ocaml-ipaddr:=
+
+ >=dev-ml/lwt-3:=
+ dev-ml/async:=
+ dev-ml/ocaml-dns:=
+ dev-ml/ocaml-ssl:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ dev-ml/findlib
+ dev-ml/ocamlbuild
+ dev-ml/ppx_driver
+ dev-ml/ppx_optcomp
+ dev-ml/ppx_sexp_conv
+"
+
+DOCS=( TODO.md README.md CHANGES )
+
+src_install() {
+ findlib_src_preinst
+ default
+}