summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-01-03 17:29:41 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-01-03 17:29:41 +0100
commitd759eefb210f1b73c89f077d3bbdc53533a82519 (patch)
tree8e096ed7ce18e2b5e75555ac6426f24c79e63fce /dev-ml/ocaml-expat
parentdev-ml/menhir: bump to 20170101 (diff)
downloadgentoo-d759eefb210f1b73c89f077d3bbdc53533a82519.tar.gz
gentoo-d759eefb210f1b73c89f077d3bbdc53533a82519.tar.bz2
gentoo-d759eefb210f1b73c89f077d3bbdc53533a82519.zip
dev-ml/ocaml-expat: bump to 1.0.0
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ml/ocaml-expat')
-rw-r--r--dev-ml/ocaml-expat/Manifest1
-rw-r--r--dev-ml/ocaml-expat/ocaml-expat-1.0.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-ml/ocaml-expat/Manifest b/dev-ml/ocaml-expat/Manifest
index ae0ee778864f..d4d3f46edf2f 100644
--- a/dev-ml/ocaml-expat/Manifest
+++ b/dev-ml/ocaml-expat/Manifest
@@ -1 +1,2 @@
DIST ocaml-expat-0.9.1.tar.gz 25223 SHA256 5fbe8c38f3ab45da5f850aae6b37183f4a8b79a63771a83d7e3d3109fc90c29a SHA512 0dca5bb3279e248acd76bc1b14511c58f2e60d8c40d806f3d270b6a47ab0e90efb636faed0dd8c34cf00a0b0834aa458421f4f9718d2a8c43dcf77854c11b3f4 WHIRLPOOL 483ca73680cba94cbf9c7573824c2085e85334b2ec33809fc895c4bce9f52d593776aad6d1761e92aeb3db2ba2a73319b8d1196647c53200c8817bcbd9e09010
+DIST ocaml-expat-1.0.0.tar.gz 58149 SHA256 69d0bc2bfef2b4310faac2bb984173a26abde5c5758152822f6807774c7abe4f SHA512 217d602ac8fabf7713dcd8fd274206b81ff467402a9bca5b15b13f3b1d68e8e5f2c2970adeafb2378c0993b39c7d98a420dee07f30ad9eb88fd40665a2f98897 WHIRLPOOL 7f3140317bfb44a2980199a4cd09ca641dcfea419317289d1528402afdaa54c1f8bcff02053ad6cebf169441ae6c2ff0906ec7b3772bc3fe7c30cd588d86c445
diff --git a/dev-ml/ocaml-expat/ocaml-expat-1.0.0.ebuild b/dev-ml/ocaml-expat/ocaml-expat-1.0.0.ebuild
new file mode 100644
index 000000000000..4da92ca0acf5
--- /dev/null
+++ b/dev-ml/ocaml-expat/ocaml-expat-1.0.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib eutils
+
+IUSE="doc +ocamlopt test"
+
+DESCRIPTION="OCaml bindings for expat"
+SRC_URI="https://github.com/whitequark/ocaml-expat/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://github.com/whitequark/ocaml-expat"
+
+RDEPEND="dev-libs/expat
+ >=dev-lang/ocaml-3.10.2:=[ocamlopt?]"
+
+DEPEND="${RDEPEND}
+ test? ( dev-ml/ounit )"
+
+SLOT="0/${PV}"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+src_compile() {
+ emake depend
+ emake all
+ if use ocamlopt; then
+ emake allopt
+ fi
+}
+
+src_test() {
+ emake test
+ if use ocamlopt; then
+ emake testopt
+ fi
+}
+src_install() {
+ findlib_src_preinst
+ emake install
+
+ if use doc ; then
+ dohtml -r doc/html/*
+ fi
+ dodoc README
+}