summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-03-14 11:20:39 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-03-14 11:21:24 +0100
commit8755f29f0640dd9e0b937f95fbfb44ba32dae6de (patch)
tree6825740c5b457ab79d12a000adcff3d9719b17a9 /dev-ml/ocaml-webmachine
parentdev-ml/ocaml-dispatch: Initial import. Ebuild by me. (diff)
downloadgentoo-8755f29f0640dd9e0b937f95fbfb44ba32dae6de.tar.gz
gentoo-8755f29f0640dd9e0b937f95fbfb44ba32dae6de.tar.bz2
gentoo-8755f29f0640dd9e0b937f95fbfb44ba32dae6de.zip
dev-ml/ocaml-webmachine: Initial import. Ebuild by me.
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-ml/ocaml-webmachine')
-rw-r--r--dev-ml/ocaml-webmachine/Manifest1
-rw-r--r--dev-ml/ocaml-webmachine/metadata.xml8
-rw-r--r--dev-ml/ocaml-webmachine/ocaml-webmachine-0.4.0.ebuild32
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-ml/ocaml-webmachine/Manifest b/dev-ml/ocaml-webmachine/Manifest
new file mode 100644
index 000000000000..9c496317a0bd
--- /dev/null
+++ b/dev-ml/ocaml-webmachine/Manifest
@@ -0,0 +1 @@
+DIST ocaml-webmachine-0.4.0.tar.gz 74818 SHA256 d0d20e41bcdf110cbabaac913c39d3a7b99002ceab403db7a76872558fec328d SHA512 5ea06ae41f6c156786b72ea7a164bd0c96cf9b6fc7ae1e93044a928681f03b07cef39da1c4955317fe6762065bd189b3809ba521b3349ec9f6dde9191c857d31 WHIRLPOOL e8adeb98816b69ce8f40df362b4b1be864b19234ee1d9ee12e0d67da77cab9ec6a21a3eccaa78c6cacbe91f5d8cea706e599c041f19277015a6e2684281a1e37
diff --git a/dev-ml/ocaml-webmachine/metadata.xml b/dev-ml/ocaml-webmachine/metadata.xml
new file mode 100644
index 000000000000..ffac4d7ebc01
--- /dev/null
+++ b/dev-ml/ocaml-webmachine/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-ml/ocaml-webmachine/ocaml-webmachine-0.4.0.ebuild b/dev-ml/ocaml-webmachine/ocaml-webmachine-0.4.0.ebuild
new file mode 100644
index 000000000000..8739af562f49
--- /dev/null
+++ b/dev-ml/ocaml-webmachine/ocaml-webmachine-0.4.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="A REST toolkit for OCaml"
+HOMEPAGE="https://github.com/inhabitedtype/ocaml-webmachine"
+SRC_URI="https://github.com/inhabitedtype/ocaml-webmachine/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-ml/calendar:=
+ dev-ml/ocaml-cohttp:=[ocamlopt?]
+ dev-ml/ocaml-dispatch:=[ocamlopt?]
+ dev-ml/ocaml-re:=[ocamlopt?]
+ dev-ml/ocaml-uri:=[ocamlopt?]
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ test? ( dev-ml/ounit[ocamlopt?] )
+"
+
+DOCS=( README.md CONTRIBUTING.md )