summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-01 13:06:35 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-01 14:24:42 +0200
commitbe45b850d2043cd22abfec60874e106bf6a113c8 (patch)
tree155b5a5d938cd2e04b0df5d59646091878764707 /dev-ml/pomap
parentdev-ml/extlib: bump to 1.7.2 (diff)
downloadgentoo-be45b850d2043cd22abfec60874e106bf6a113c8.tar.gz
gentoo-be45b850d2043cd22abfec60874e106bf6a113c8.tar.bz2
gentoo-be45b850d2043cd22abfec60874e106bf6a113c8.zip
dev-ml/pomap: Bump to 3.0.7
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ml/pomap')
-rw-r--r--dev-ml/pomap/Manifest1
-rw-r--r--dev-ml/pomap/pomap-3.0.7.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-ml/pomap/Manifest b/dev-ml/pomap/Manifest
index fba4ec53875c..456600d07df7 100644
--- a/dev-ml/pomap/Manifest
+++ b/dev-ml/pomap/Manifest
@@ -1 +1,2 @@
DIST pomap-3.0.6.tar.gz 75345 SHA256 b9884487c1692d01de3c985894e06f820113f05d08f92909d817528b51e23f55 SHA512 c9b91b7eb3716f4ba735928bb7d33202fe4b05d3908afad36cffa01ffa5fa8f860b3a9d57a0b5bbf2577bb84f3a5b464ec85375e488a3fd5f8d99d7bbcf141a8 WHIRLPOOL b4edb268417d7dbeb31e972f81ba3d4669aac8a82645b24474e8db62b70402c5737402c690a2b69599da101021a99b2350728b03d1f76654008c42bb398966cc
+DIST pomap-3.0.7.tar.gz 80880 SHA256 a67e25d2e7cb80ab52f18cf9bb6cbf098c25ff28dfd01e7bab8d7d0e50266464 SHA512 f4f59708c1a638211332444310aae903eead9dfe9900034698a19ead275fe8d95a32f74bd8e062f7d5d671bbd92cdf18052f26a1e2fd07724c37f60b304f66ba WHIRLPOOL fb82d50839e9082251b5d2c4e97f08ddefd6c989c5a190f45bf5d5181d06556a0f7efd31047365a80356c37e72e298d614c9ff5f10850da85e607c57b09d14ae
diff --git a/dev-ml/pomap/pomap-3.0.7.ebuild b/dev-ml/pomap/pomap-3.0.7.ebuild
new file mode 100644
index 000000000000..843be10b3fb5
--- /dev/null
+++ b/dev-ml/pomap/pomap-3.0.7.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="Partially Ordered Map ADT for O'Caml"
+HOMEPAGE="http://mmottl.github.io/pomap/"
+SRC_URI="https://github.com/mmottl/pomap/releases/download/v${PV}/${P}.tar.gz"
+LICENSE="LGPL-2.1-with-linking-exception"
+
+DEPEND="dev-ml/camlp4:="
+RDEPEND="${DEPEND}"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="examples"
+
+DOCS=( "AUTHORS.txt" "CHANGES.txt" "README.md" )
+
+src_install() {
+ oasis_src_install
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}