summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-16 21:41:34 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-17 10:35:14 +0200
commit26ed2d46d2a790597328d86357ef70788b53537f (patch)
treef582adf92f5bd3c5e63b77299083bd9f7b01001b /dev-ml/ppx_sexp_conv/ppx_sexp_conv-0.9.0-r1.ebuild
parentdev-ml/ppx_fields_conv: revbump for propagating previous fix (diff)
downloadgentoo-26ed2d46d2a790597328d86357ef70788b53537f.tar.gz
gentoo-26ed2d46d2a790597328d86357ef70788b53537f.tar.bz2
gentoo-26ed2d46d2a790597328d86357ef70788b53537f.zip
dev-ml/ppx_sexp_conv: revbump for propagating previous fix
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ml/ppx_sexp_conv/ppx_sexp_conv-0.9.0-r1.ebuild')
-rw-r--r--dev-ml/ppx_sexp_conv/ppx_sexp_conv-0.9.0-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ml/ppx_sexp_conv/ppx_sexp_conv-0.9.0-r1.ebuild b/dev-ml/ppx_sexp_conv/ppx_sexp_conv-0.9.0-r1.ebuild
new file mode 100644
index 000000000000..1ed53355c24d
--- /dev/null
+++ b/dev-ml/ppx_sexp_conv/ppx_sexp_conv-0.9.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Support Library for type-driven code generators"
+HOMEPAGE="https://github.com/janestreet/ppx_sexp_conv"
+SRC_URI="https://github.com/janestreet/ppx_sexp_conv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-lang/ocaml:=
+ dev-ml/ppx_core:=
+ dev-ml/ppx_driver:=
+ dev-ml/ppx_type_conv:=
+ dev-ml/ppx_metaquot:=
+ dev-ml/ppx_optcomp:=
+ dev-ml/sexplib:=
+ dev-ml/ocaml-migrate-parsetree:=
+ "
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND} dev-ml/opam dev-ml/jbuilder"
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+}