summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-07-07 22:05:58 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-07-07 22:06:12 +0200
commitc8473fe746afae1916c0cb7350142bf6c3c6e0fa (patch)
treea8bb123a6fb9155e75c3689631f3a013cd39ab85 /dev-ml/ppx_tools
parentapp-crypt/yubikey-manager: add support for python3.6 (diff)
downloadgentoo-c8473fe746afae1916c0cb7350142bf6c3c6e0fa.tar.gz
gentoo-c8473fe746afae1916c0cb7350142bf6c3c6e0fa.tar.bz2
gentoo-c8473fe746afae1916c0cb7350142bf6c3c6e0fa.zip
dev-ml/ppx_tools: add ocamlopt useflag, bug #624170
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ml/ppx_tools')
-rw-r--r--dev-ml/ppx_tools/ppx_tools-5.0.4.03.0.ebuild6
-rw-r--r--dev-ml/ppx_tools/ppx_tools-5.0.4.05.0.ebuild6
2 files changed, 6 insertions, 6 deletions
diff --git a/dev-ml/ppx_tools/ppx_tools-5.0.4.03.0.ebuild b/dev-ml/ppx_tools/ppx_tools-5.0.4.03.0.ebuild
index 752f91c602a..b77cef7d6d7 100644
--- a/dev-ml/ppx_tools/ppx_tools-5.0.4.03.0.ebuild
+++ b/dev-ml/ppx_tools/ppx_tools-5.0.4.03.0.ebuild
@@ -13,9 +13,9 @@ SRC_URI="https://github.com/alainfrisch/ppx_tools/archive/${MY_PV}.tar.gz -> ${P
LICENSE="MIT"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc"
-IUSE=""
+IUSE="+ocamlopt"
-DEPEND=">=dev-lang/ocaml-4.03.0:="
+DEPEND=">=dev-lang/ocaml-4.03.0:=[ocamlopt?]"
RDEPEND="${DEPEND}"
S="${WORKDIR}/${PN}-$(replace_version_separator 2 '-')"
@@ -24,7 +24,7 @@ src_prepare() {
}
src_compile() {
- emake -j1
+ emake -j1 $(usex ocamlopt "" "ARCH=none")
}
src_install() {
diff --git a/dev-ml/ppx_tools/ppx_tools-5.0.4.05.0.ebuild b/dev-ml/ppx_tools/ppx_tools-5.0.4.05.0.ebuild
index 4a923db8275..2ec6b114e82 100644
--- a/dev-ml/ppx_tools/ppx_tools-5.0.4.05.0.ebuild
+++ b/dev-ml/ppx_tools/ppx_tools-5.0.4.05.0.ebuild
@@ -13,14 +13,14 @@ SRC_URI="https://github.com/alainfrisch/ppx_tools/archive/${MY_PV}.tar.gz -> ${P
LICENSE="MIT"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc"
-IUSE=""
+IUSE="+ocamlopt"
-DEPEND=">=dev-lang/ocaml-4.05_beta:="
+DEPEND=">=dev-lang/ocaml-4.05_beta:=[ocamlopt?]"
RDEPEND="${DEPEND}"
S="${WORKDIR}/${PN}-$(replace_version_separator 2 '-')"
src_compile() {
- emake -j1
+ emake -j1 $(usex ocamlopt "" "ARCH=none")
}
src_install() {