summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-05 12:34:39 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-03-05 12:34:48 +0100
commit4605f547d68ab214815b3b21a662aea3c9cb744d (patch)
tree56e1a66d419e2642e4bb58844cc5c96d4b30bd1c /dev-ml/pxp
parentdev-ml/ocamlnet: bump to 4.1.1 (diff)
downloadgentoo-4605f547d68ab214815b3b21a662aea3c9cb744d.tar.gz
gentoo-4605f547d68ab214815b3b21a662aea3c9cb744d.tar.bz2
gentoo-4605f547d68ab214815b3b21a662aea3c9cb744d.zip
dev-ml/pxp: bump to 1.2.8
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml/pxp')
-rw-r--r--dev-ml/pxp/Manifest1
-rw-r--r--dev-ml/pxp/pxp-1.2.8.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-ml/pxp/Manifest b/dev-ml/pxp/Manifest
index eff83f850bbd..a1a43279c326 100644
--- a/dev-ml/pxp/Manifest
+++ b/dev-ml/pxp/Manifest
@@ -1,2 +1,3 @@
DIST pxp-1.2.4.tar.gz 702365 SHA256 1cd3e946f19d800f412475adf56e6da87231f80be22d7ea71dd4eabf93876355 SHA512 1520dd732db17923c24d43c328e659db83ac00569e7d2153e5633dfbc3fad899db8e45523ea76915e5dd1cb71cda2500db3875deebdf47b375af5bd05ad383d6 WHIRLPOOL 26c54816a63b26cee4cbaa7c3c868f449c40291eff1a242ade45f5c08f89afd7ef8b12ff3da5b00608f8ede486d17b1fd1387f0042c42e79d08e76f43c97089f
DIST pxp-1.2.7.tar.gz 735710 SHA256 2b0aca564f71c87825436e31a82de2ca3b3e99ee81a83840a525b0be63d73025 SHA512 11b49edc8e93a867b39d99ed6117460b3ecc7f9368564c815125662897f3cfbd87876b68c794bfd73b28cb0d8a898500ccd8ce0e1fca205bbce8b9759fa684d3 WHIRLPOOL 728f708c5dc332179884a4c2b6a222c514e8153c3bdf67847361df323886d61e320672f7dc7bd695343a641b34c9742c94f3cd9065541622670cb8b3df22380d
+DIST pxp-1.2.8.tar.gz 619689 SHA256 701754f4460595434ea6db77c33e046d33e4a485e8d28c5d39ced56112c94452 SHA512 3292bfbda494066e454331a9cfc56b03f55afe8548bdf24fea09d9bc0a03c333c027f7b527983bd9b4d659458c95acf7e3fc251c72d26ab3502f52067c9f2549 WHIRLPOOL 5529a6ad818428b03664764704e62d200802dc26c8c344897f4b15b17945e4620fa4b878f0108b12f346000a7cc070b50d2ce82d945c6bcd34a0e5e811ec8c0a
diff --git a/dev-ml/pxp/pxp-1.2.8.ebuild b/dev-ml/pxp/pxp-1.2.8.ebuild
new file mode 100644
index 000000000000..1937ee73d8e9
--- /dev/null
+++ b/dev-ml/pxp/pxp-1.2.8.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit findlib eutils
+
+MY_P=${P/_beta/test}
+
+DESCRIPTION="validating XML parser library for O'Caml"
+HOMEPAGE="http://projects.camlcity.org/projects/pxp.html"
+SRC_URI="http://download.camlcity.org/download/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+SLOT="0/${PV}"
+DEPEND=">=dev-ml/pcre-ocaml-4.31:=
+ >=dev-ml/ulex-0.5:=
+ >=dev-ml/ocamlnet-0.98:=
+ >=dev-lang/ocaml-3.10.2:=[ocamlopt?]
+ || ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )"
+RDEPEND="${DEPEND}"
+
+IUSE="examples +ocamlopt"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ #the included configure does not support many standard switches and is quite picky
+ ./configure || die "configure failed"
+}
+
+src_compile() {
+ emake -j1 all
+ if use ocamlopt; then
+ emake -j1 opt
+ fi
+}
+
+src_install() {
+ findlib_src_install
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ cd doc
+ dodoc ABOUT-FINDLIB README SPEC design.txt
+}