summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ml/ulex
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ml/ulex')
-rw-r--r--dev-ml/ulex/Manifest1
-rw-r--r--dev-ml/ulex/metadata.xml5
-rw-r--r--dev-ml/ulex/ulex-1.1.ebuild32
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-ml/ulex/Manifest b/dev-ml/ulex/Manifest
new file mode 100644
index 000000000000..f700daefb2bc
--- /dev/null
+++ b/dev-ml/ulex/Manifest
@@ -0,0 +1 @@
+DIST ulex-1.1.tar.gz 20347 SHA256 a01ff3223b295c5b24ee414bb9e9add14357ccf364addcfa734d91a02f9f543a SHA512 7840707705e8403cef6586b072d722043adf9a867a1f4209e1f3ad1a97797c2b292e5151b7714b37fa9aacb190eb0a0a35be1b7675bfaca46f1f68bda58cec70 WHIRLPOOL da1729c80a590fd3a1efeaab7cc57103ad2f41dc6baf4edb74a041935a3ffbd5aaf6120baba76b6f7ea3e0ead6c5cc4bf695dca79be10daeb46064c4b90c08d0
diff --git a/dev-ml/ulex/metadata.xml b/dev-ml/ulex/metadata.xml
new file mode 100644
index 000000000000..2193d772e351
--- /dev/null
+++ b/dev-ml/ulex/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ml</herd>
+</pkgmetadata>
diff --git a/dev-ml/ulex/ulex-1.1.ebuild b/dev-ml/ulex/ulex-1.1.ebuild
new file mode 100644
index 000000000000..5ae79cbebc2f
--- /dev/null
+++ b/dev-ml/ulex/ulex-1.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils findlib
+
+DESCRIPTION="A lexer generator for unicode"
+HOMEPAGE="http://www.cduce.org"
+SRC_URI="http://www.cduce.org/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ppc x86"
+IUSE="+ocamlopt"
+
+DEPEND=">=dev-lang/ocaml-3.10.2:=[ocamlopt?]
+ || ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake all
+ if use ocamlopt; then
+ emake all.opt
+ fi
+}
+
+src_install() {
+ findlib_src_install
+ dodoc README CHANGES
+}