summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ml/xml-light/xml-light-2.2-r3.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ml/xml-light/xml-light-2.2-r3.ebuild')
-rw-r--r--dev-ml/xml-light/xml-light-2.2-r3.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/dev-ml/xml-light/xml-light-2.2-r3.ebuild b/dev-ml/xml-light/xml-light-2.2-r3.ebuild
new file mode 100644
index 000000000000..f36db670bee1
--- /dev/null
+++ b/dev-ml/xml-light/xml-light-2.2-r3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib
+
+DESCRIPTION="Minimal Xml parser and printer for OCaml"
+HOMEPAGE="http://tech.motion-twin.com/xmllight.html"
+SRC_URI="http://tech.motion-twin.com/zip/${P}.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE="doc +ocamlopt"
+
+RDEPEND="dev-lang/ocaml:=[ocamlopt?]"
+DEPEND="app-arch/unzip
+ ${RDEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ EPATCH_FORCE=yes EPATCH_SUFFIX=dpatch EPATCH_SOURCE="${FILESDIR}" \
+ epatch
+}
+
+src_compile() {
+ emake -j1
+ if use ocamlopt; then
+ emake -j1 opt
+ fi
+ if use doc;then
+ emake doc
+ fi
+}
+
+src_test() {
+ # There are no tests...
+ :
+}
+
+src_install() {
+ dodir /usr/$(get_libdir)/ocaml/${PN}
+ emake INSTALLDIR="${D}"/usr/$(get_libdir)/ocaml/${PN} install
+ cat > "${D}"/usr/$(get_libdir)/ocaml/${PN}/META << EOF
+name="${PN}"
+version="${PV}"
+description="${DESCRIPTION}"
+requires=""
+archive(byte)="xml-light.cma"
+EOF
+ if use ocamlopt; then
+ emake INSTALLDIR="${D}"/usr/$(get_libdir)/ocaml/${PN} installopt
+ echo 'archive(native)="xml-light.cmxa"' >> "${D}"/usr/$(get_libdir)/ocaml/${PN}/META
+ fi
+ dodoc README
+ if use doc; then
+ emake doc
+ dohtml doc/*
+ fi
+}