summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ml/zed
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ml/zed')
-rw-r--r--dev-ml/zed/Manifest2
-rw-r--r--dev-ml/zed/metadata.xml8
-rw-r--r--dev-ml/zed/zed-1.2.ebuild27
-rw-r--r--dev-ml/zed/zed-1.4.ebuild22
4 files changed, 59 insertions, 0 deletions
diff --git a/dev-ml/zed/Manifest b/dev-ml/zed/Manifest
new file mode 100644
index 000000000000..2b40827ce990
--- /dev/null
+++ b/dev-ml/zed/Manifest
@@ -0,0 +1,2 @@
+DIST zed-1.2.tar.gz 68672 SHA256 6fc770d9da1233477e3f58ddfa7d048e805ef15080a6e630341df847529b29db SHA512 59cbafa2d7bbf17b7757798446640c5365ca825fec0a1cda320f0fdd2db1158ff4bc99aef6400ae090cd81c80fe4d5b50803da86ee154f6025469dc390e7c1fc WHIRLPOOL a262987f08093a3e891e225f376039e974e92c6823fd1aeebb454bf3825375b5da64175915a3f56efa5a63f28d5811f495cdac44d8dc63002597b56ebf29af24
+DIST zed-1.4.tar.gz 73265 SHA256 df72f7c248e993523ba401d9b1958471f2c88dfe7bcc61f5247b2e3863c26e5f SHA512 8a8d308ce09f141624f82ce989094cec51018cf805b60b2522002e6e2a17d27c3b994d73649b7a4118dd1355b24820de9ed8dc4dc295d3931f7cf0baf7889295 WHIRLPOOL f1ef565a470852de6684b3b7fd515ef1581c654275e7509480c5c7d60e3d63d3057794e0efa2502e8ff240873afed1fd193e6e7cc3e55218b5f4867264c5e7b6
diff --git a/dev-ml/zed/metadata.xml b/dev-ml/zed/metadata.xml
new file mode 100644
index 000000000000..4025bbe5fd5c
--- /dev/null
+++ b/dev-ml/zed/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ml</herd>
+ <upstream>
+ <remote-id type="github">diml/zed</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/zed/zed-1.2.ebuild b/dev-ml/zed/zed-1.2.ebuild
new file mode 100644
index 000000000000..647fb3f7459b
--- /dev/null
+++ b/dev-ml/zed/zed-1.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+inherit oasis
+
+DESCRIPTION="Zed is an abstract engine for text edition"
+HOMEPAGE="http://forge.ocamlcore.org/projects/zed/"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/944/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-ml/camomile:=
+ dev-ml/react:="
+RDEPEND="${DEPEND}"
+DOCS=( "CHANGES" )
+
+src_prepare() {
+ #bug 1105 upstream
+ sed -i "s/<code>/< code >/" src/zed_edit.mli
+}
diff --git a/dev-ml/zed/zed-1.4.ebuild b/dev-ml/zed/zed-1.4.ebuild
new file mode 100644
index 000000000000..6b99baa2c664
--- /dev/null
+++ b/dev-ml/zed/zed-1.4.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+inherit oasis
+
+DESCRIPTION="Zed is an abstract engine for text edition"
+HOMEPAGE="https://github.com/diml/zed"
+SRC_URI="https://github.com/diml/zed/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-ml/camomile:=
+ dev-ml/react:="
+RDEPEND="${DEPEND}"
+DOCS=( "CHANGES.md" "README.md" )