summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-22 10:23:31 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-03-22 11:06:54 +0100
commit03403769dc8b535cbfee56b5e51a328ccaa428d5 (patch)
tree87b3c4c935ead39e16eda592e567337d29ef09fd /dev-ml
parentdev-ml/ppx_fail: bump to 113.33.00 (diff)
downloadgentoo-03403769dc8b535cbfee56b5e51a328ccaa428d5.tar.gz
gentoo-03403769dc8b535cbfee56b5e51a328ccaa428d5.tar.bz2
gentoo-03403769dc8b535cbfee56b5e51a328ccaa428d5.zip
dev-ml/ppx_expect: bump to 113.33.00
Package-Manager: portage-2.2.28 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ppx_expect/Manifest1
-rw-r--r--dev-ml/ppx_expect/ppx_expect-113.33.00.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-ml/ppx_expect/Manifest b/dev-ml/ppx_expect/Manifest
index 2737f4d05215..845d2a4c0b1c 100644
--- a/dev-ml/ppx_expect/Manifest
+++ b/dev-ml/ppx_expect/Manifest
@@ -1 +1,2 @@
DIST ppx_expect-113.24.00.tar.gz 69986 SHA256 c06ab7c70219da64c0d334ab91aad9f58d52b6e9303ab5669f5674e0439f3ad9 SHA512 194384db2cd8dc2994cbf7b4d8f0480d11e8c4b23fee3e893afcfdbca67ba931c80b870b48de9e60ee442401f6661e2dbc599d1a33705dc00dcf991c1a71032a WHIRLPOOL 17d8725aa40a12cf5f9f41d4bed720303d601f1becec77685ba20593d23f6a8b71c1c2ff289938196b65ce75d16661011780dc246614902b52d6da87a41b3d8c
+DIST ppx_expect-113.33.00.tar.gz 79133 SHA256 3a0c8e20e9eafe79d800eb6a2bc0d83ce3b2d8739a55b902d6f5a8af21cb9a6b SHA512 9e2c12c4d5a874213f1cc8ece3bd8cc832796dcb40561350077355f4fa8539b77a4bf5e37f374b4de1d872de6ffb1f1f0974211d6cc69c35c07b0e55c1edf7c4 WHIRLPOOL ea27180ffc49944e66bc645eabc2cba21eb947536c0aba145992fa40c6e36a9fcab2f4ee541d3982aacf457051349219ba401973381b21da8a7d28e96864bdad
diff --git a/dev-ml/ppx_expect/ppx_expect-113.33.00.ebuild b/dev-ml/ppx_expect/ppx_expect-113.33.00.ebuild
new file mode 100644
index 000000000000..c605caa63581
--- /dev/null
+++ b/dev-ml/ppx_expect/ppx_expect-113.33.00.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit oasis
+
+DESCRIPTION="Cram like framework for OCaml"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-ml/ppx_tools:=
+ dev-ml/fieldslib:=
+ dev-ml/ppx_assert:=
+ dev-ml/ppx_compare:=
+ dev-ml/ppx_core:=
+ dev-ml/ppx_custom_printf:=
+ dev-ml/ppx_driver:=
+ dev-ml/ppx_fields_conv:=
+ dev-ml/ppx_inline_test:=
+ dev-ml/ppx_sexp_conv:=
+ dev-ml/ppx_sexp_value:=
+ dev-ml/ppx_variants_conv:=
+ dev-ml/ocaml-re:=
+ dev-ml/sexplib:=
+ dev-ml/variantslib:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND} dev-ml/opam"
+
+src_configure() {
+ emake setup.exe
+ OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+ dodoc CHANGES.md
+}