summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-05-09 08:32:50 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-05-09 09:14:20 +0200
commit06ef239fb9fc9da46b4f5230d0026a97b71e7002 (patch)
tree57fd6a5d8f9bcffdad2e66c0253bd7bf88538629 /dev-ml
parentros-meta/viz: bump to 1.3.1 (diff)
downloadgentoo-06ef239fb9fc9da46b4f5230d0026a97b71e7002.tar.gz
gentoo-06ef239fb9fc9da46b4f5230d0026a97b71e7002.tar.bz2
gentoo-06ef239fb9fc9da46b4f5230d0026a97b71e7002.zip
dev-ml/ocaml-containers: Bump to 1.2
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-containers/Manifest1
-rw-r--r--dev-ml/ocaml-containers/ocaml-containers-1.2.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-ml/ocaml-containers/Manifest b/dev-ml/ocaml-containers/Manifest
index cb342539a991..9dff33506784 100644
--- a/dev-ml/ocaml-containers/Manifest
+++ b/dev-ml/ocaml-containers/Manifest
@@ -1,3 +1,4 @@
DIST ocaml-containers-0.22.1.tar.gz 429672 SHA256 2ef64e8ed93211dfd4f8cd594943db3cde81ee0400b17703d8a7993128634622 SHA512 9294d43485cd17998f9d0c758ee0ffdc187ea78f1f456c0b06a57a9401c6de529e9e68bad12908b2b0da5f22fca64835acb90f3dfd6ee3403bb7c3c301cd6821 WHIRLPOOL 67844578447b321439223b5f560258cb5d5417135dfdbfdaf2fa10e104beb764e9ca6ae0ab774864c974d928e75aa5aedc7e90ea5659d910f33349a7ec4b568b
DIST ocaml-containers-1.0.tar.gz 378474 SHA256 d31239782eda4ffddc6358add3089e3a389aab7682b8202fd7db90075a703e75 SHA512 a22bd66c522f734c6081d1675af3d110cf1e9b4d3bd066aa9366c25fc840890a4ef779fa68ded84ef1b09df37fa7c217dfed1c15b1243f511ebfd24d7f0d2590 WHIRLPOOL a883d3052b400f66905441720164ee68e51353a4940ddcec0d05bef08533549dad7d428fce05d49a235a5a6586b3aca23ec757cf5abff6f4d84d5b75b8751569
DIST ocaml-containers-1.1.tar.gz 284852 SHA256 b8255217d5e797fe40d997b59558f1152a55f59a621c963ba7da5a00242e2f3d SHA512 8a01ae019fcebf540972e64fed70abec7a0af8a7686bbc230734e5717cb2c4dfdb239ac145126e8243da9770475e34147fd631f6344947145b3c2a41d10e6152 WHIRLPOOL 479385c85b34805087b56d158be10849251fec0c00e00f73ba7886a76a2e09080995aa62e49795abe34a01c52d7a6789d5041c5cb497f65e323cac2fb4ef6cf3
+DIST ocaml-containers-1.2.tar.gz 293774 SHA256 1c7825fbefaf90c3f9f9367ce0abda95f1dda242b1db560ed51c75ef0c6b5b15 SHA512 c5d94760a51a94aca1482ce3720450bce4448090609737a5be50f99c8884441df4676da953b31bdb8f10dd2fca3235b6e9e8d1580bd3fa917b03408a9a14b28d WHIRLPOOL a365c6992d926d2c4045da0a39052c7eba71eb3c937eca126a186e393fefdf199fe1e40f5cde21539df914e235ce8e3dcd7712da86160a2ef1631cf223c3be65
diff --git a/dev-ml/ocaml-containers/ocaml-containers-1.2.ebuild b/dev-ml/ocaml-containers/ocaml-containers-1.2.ebuild
new file mode 100644
index 000000000000..363fc9ba1463
--- /dev/null
+++ b/dev-ml/ocaml-containers/ocaml-containers-1.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+OASIS_BUILD_TESTS=1
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="A modular standard library focused on data structures"
+HOMEPAGE="https://github.com/c-cube/ocaml-containers"
+SRC_URI="https://github.com/c-cube/ocaml-containers/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+# Breaks onanomsg, its sole revdep
+#KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ dev-ml/result:=
+ >=dev-ml/sequence-0.9:=
+"
+DEPEND="${RDEPEND} dev-ml/cppo
+ test? ( dev-ml/iTeML dev-ml/ounit dev-ml/gen )"
+
+src_configure() {
+ oasis_configure_opts="
+ --enable-unix
+ --disable-bench
+ " oasis_src_configure
+}