summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-06-23 13:35:32 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-06-23 13:35:32 +0200
commit1486b065f058d6215fec9957412eff1822934fde (patch)
treee7ad82139f04214046bff956fb316757ca43cb84 /dev-ml
parentdev-ml/pomap: remove old (diff)
downloadgentoo-1486b065f058d6215fec9957412eff1822934fde.tar.gz
gentoo-1486b065f058d6215fec9957412eff1822934fde.tar.bz2
gentoo-1486b065f058d6215fec9957412eff1822934fde.zip
dev-ml/pomap: drop backward compat dep on camlp4; part of bug #586304
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/pomap/pomap-3.0.5-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ml/pomap/pomap-3.0.5-r1.ebuild b/dev-ml/pomap/pomap-3.0.5-r1.ebuild
new file mode 100644
index 000000000000..f8b0cc700562
--- /dev/null
+++ b/dev-ml/pomap/pomap-3.0.5-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="Partially Ordered Map ADT for O'Caml"
+HOMEPAGE="http://mmottl.github.io/pomap/"
+SRC_URI="https://github.com/mmottl/pomap/releases/download/v${PV}/${P}.tar.gz"
+LICENSE="LGPL-2.1-with-linking-exception"
+
+DEPEND="dev-ml/camlp4:="
+RDEPEND="${DEPEND}"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="examples"
+
+DOCS=( "AUTHORS.txt" "CHANGES.txt" "README.md" )
+
+src_install() {
+ oasis_src_install
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}