summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-08-23 14:23:39 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-08-23 17:11:25 +0200
commit211ff9d171d1bfae34ca82b51fb799580b53d09c (patch)
tree44b8ae2feb5bb4781f7893de4574a0bfdc0353a0 /dev-ml
parentdev-ros/moveit_msgs: bump to 0.8.3 (diff)
downloadgentoo-211ff9d171d1bfae34ca82b51fb799580b53d09c.tar.gz
gentoo-211ff9d171d1bfae34ca82b51fb799580b53d09c.tar.bz2
gentoo-211ff9d171d1bfae34ca82b51fb799580b53d09c.zip
dev-ml/ocaml-ctypes: bump to 0.9.0
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-ctypes/Manifest1
-rw-r--r--dev-ml/ocaml-ctypes/ocaml-ctypes-0.9.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-ml/ocaml-ctypes/Manifest b/dev-ml/ocaml-ctypes/Manifest
index 30c8480dfe41..41c5db1a1edc 100644
--- a/dev-ml/ocaml-ctypes/Manifest
+++ b/dev-ml/ocaml-ctypes/Manifest
@@ -2,3 +2,4 @@ DIST ocaml-ctypes-0.4.1.tar.gz 162601 SHA256 74564e049de5d3c0e76ea284c225cb658ac
DIST ocaml-ctypes-0.6.2.tar.gz 179953 SHA256 f31671c6515b9f9df245ec08e8ac6842cf33b7d9b76799cc07f8b77b093de55f SHA512 65b975f51daa29f59c07eec558eb5f688452a8e30edeeeca186d60f4cb56e087c5943b6f59d7dfa5f69ae9cace22ecc135148f99754693af684fd75178dafa24 WHIRLPOOL ad016187e9ce0657d38b8d98a986e9886e01b5f21f2090e89ba6d6dc91e16fce91c9d284b826f4dd1e46b9ffd9df3a4656f22e2023cece5994642a74547501c4
DIST ocaml-ctypes-0.7.0.tar.gz 181164 SHA256 8a68597b8545b36d7ced83a3365767ad0ebae99382ca7c8fff2a97666a78f94c SHA512 78929d4d9dd47e08751231a649f74259973333ecae84e6152b0a3e16a78da6b8b95bd8f69842b3b052324ecf96457eaa2b894557888aa53271917f9135259353 WHIRLPOOL 4edab9bacbea2f01676f0adc8b7058acd6097808c9d53e6d47320341de127634a3c0db3cdfd54678fdc97cb1bae8400ae79f8c5f5d55a921a3555d4f7c4ddc3a
DIST ocaml-ctypes-0.8.0.tar.gz 182704 SHA256 db465ec1bc5c0222b2fe167065d35d588cdfaf8910bcf51e0a444d528c24b32a SHA512 6478a63643fbf56391e0ab982f535afc55a79af6723a04420b156d0e5da891eff3233259083d37a35f4a15242b291bd11f5d08608fa5a9f95e6faaf434b04e68 WHIRLPOOL 0fffc7c4994c6435ac349dac176f24fcda7273db7a02f6ee2c329f98f293ac8b51aaba1a1c7d053e8527e89c6ae4d15102badc921e396139eb594f8bc8acd61d
+DIST ocaml-ctypes-0.9.0.tar.gz 185021 SHA256 6a8e29447c2b24c8f4c4e5ae6f9580f42aaaa7c59ef92ed1a2944b097d87b9f3 SHA512 f94ed96b4df8b8fb11eb6d3bede7dd9d59427d3bf48357d51b32e967c3d97f6dc9f6180fa0b6e69c886a586a13ecc7ed39eff532dc499daf8117bdc1ce577410 WHIRLPOOL afc6c37bde106138cc852318f1e5db7c32cae87aee9bbe1730ad0e7e7ad1983495a1c200af3d864454eebf07fc40e8e12c0264296b1772d6a91964e507168fc9
diff --git a/dev-ml/ocaml-ctypes/ocaml-ctypes-0.9.0.ebuild b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.9.0.ebuild
new file mode 100644
index 000000000000..d563719db9e5
--- /dev/null
+++ b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.9.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Library for binding to C libraries using pure OCaml"
+HOMEPAGE="https://github.com/ocamllabs/ocaml-ctypes"
+SRC_URI="https://github.com/ocamllabs/ocaml-ctypes/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.02:=[ocamlopt]
+ virtual/libffi
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ml/ounit )"
+
+src_compile() {
+ emake -j1
+}
+
+src_test() {
+ emake -j1 test
+}
+
+src_install() {
+ findlib_src_install
+ dodoc CHANGES.md README.md
+}