summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-03-11 11:31:24 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-03-11 11:31:38 +0100
commit218f1f1600537f011869669b196b05e0937fc746 (patch)
tree6a25587ef24f256b0633764b51ea22b6bf5fe4b5 /dev-ml
parentdev-ml/logs: Enable fmt & lwt by default. (diff)
downloadgentoo-218f1f1600537f011869669b196b05e0937fc746.tar.gz
gentoo-218f1f1600537f011869669b196b05e0937fc746.tar.bz2
gentoo-218f1f1600537f011869669b196b05e0937fc746.zip
dev-ml/ocaml-cohttp: Initial import. Ebuild by me.
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-cohttp/Manifest1
-rw-r--r--dev-ml/ocaml-cohttp/metadata.xml12
-rw-r--r--dev-ml/ocaml-cohttp/ocaml-cohttp-0.22.0.ebuild62
3 files changed, 75 insertions, 0 deletions
diff --git a/dev-ml/ocaml-cohttp/Manifest b/dev-ml/ocaml-cohttp/Manifest
new file mode 100644
index 000000000000..2a2970077b99
--- /dev/null
+++ b/dev-ml/ocaml-cohttp/Manifest
@@ -0,0 +1 @@
+DIST ocaml-cohttp-0.22.0.tar.gz 194568 SHA256 706a3851b54ce9feb5bf3184a5e95ab79128756f2b31b646e7a69c82cb4e7678 SHA512 60ae828a3e2085d5468f5d177f50a8e7a02ed47b8036af5548996ba3d36d8eef756662259abc65035c5d1f4158c9760762ac5f85376d6bfc76a7f027f01fa5b2 WHIRLPOOL 5c66d8d5ddf7acc5484a5970236e4e972dfb82b6354dd6894ad265f2f5e97b6c6709e7dded8d29ff7942c563d421894ed17d34f2765020337b2016b734793822
diff --git a/dev-ml/ocaml-cohttp/metadata.xml b/dev-ml/ocaml-cohttp/metadata.xml
new file mode 100644
index 000000000000..fa5c1b148efa
--- /dev/null
+++ b/dev-ml/ocaml-cohttp/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+</maintainer>
+ <use>
+ <flag name="async">Enables support for the <pkg>dev-ml/async</pkg> asynchronous execution library.</flag>
+ <flag name="lwt">Enables support for the <pkg>dev-ml/lwt</pkg> cooperative light-weight thread library.</flag>
+ </use>
+</pkgmetadata>
diff --git a/dev-ml/ocaml-cohttp/ocaml-cohttp-0.22.0.ebuild b/dev-ml/ocaml-cohttp/ocaml-cohttp-0.22.0.ebuild
new file mode 100644
index 000000000000..bb00e40e1629
--- /dev/null
+++ b/dev-ml/ocaml-cohttp/ocaml-cohttp-0.22.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+OASIS_BUILD_TESTS=1
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="Very lightweight HTTP server using Lwt or Async"
+HOMEPAGE="https://github.com/mirage/ocaml-cohttp"
+SRC_URI="https://github.com/mirage/ocaml-cohttp/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="async javascript +lwt"
+
+DEPEND="
+ dev-ml/ocaml-re:=
+ dev-ml/stringext:=
+ dev-ml/ocaml-uri:=
+ dev-ml/fieldslib:=
+ dev-ml/sexplib:=
+ dev-ml/ppx_fields_conv:=
+ dev-ml/ppx_sexp_conv:=
+ dev-ml/ocaml-base64:=
+ lwt? (
+ dev-ml/lwt:=
+ dev-ml/logs:=[fmt,lwt]
+ dev-ml/cmdliner:=
+ dev-ml/ocaml-conduit:=
+ dev-ml/ocaml-magic-mime:=
+ )
+ async? (
+ dev-ml/ocaml-conduit:=
+ dev-ml/logs:=[fmt]
+ dev-ml/ocaml-magic-mime:=
+ dev-ml/fmt:=
+ )
+ javascript? (
+ dev-ml/js_of_ocaml:=[ppx]
+ )
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ test? (
+ dev-ml/ounit
+ dev-ml/alcotest
+ )
+"
+DOCS=( README.md CHANGES DESIGN.md TODO.md )
+
+src_configure() {
+ local oasis_configure_opts="
+ $(use_enable lwt) $(use_enable lwt lwt-unix)
+ $(use_enable async)
+ $(use_enable javascript js)
+ "
+ oasis_src_configure
+}