summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-22 09:53:47 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-03-22 10:20:02 +0100
commit22841f5df0e83d780d9834110789981742c307e5 (patch)
tree9331362cc56d14efb95d190d7471d59d3b68d0df /dev-ml
parentdev-ml/ppx_type_conv: bump to 113.33.00 (diff)
downloadgentoo-22841f5df0e83d780d9834110789981742c307e5.tar.gz
gentoo-22841f5df0e83d780d9834110789981742c307e5.tar.bz2
gentoo-22841f5df0e83d780d9834110789981742c307e5.zip
dev-ml/ppx_sexp_value: bump to 113.33.00
Package-Manager: portage-2.2.28 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ppx_sexp_value/Manifest1
-rw-r--r--dev-ml/ppx_sexp_value/ppx_sexp_value-113.33.00.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-ml/ppx_sexp_value/Manifest b/dev-ml/ppx_sexp_value/Manifest
index a1df05d94219..fa172bcbf638 100644
--- a/dev-ml/ppx_sexp_value/Manifest
+++ b/dev-ml/ppx_sexp_value/Manifest
@@ -1 +1,2 @@
DIST ppx_sexp_value-113.24.00.tar.gz 56003 SHA256 3f807c867075ea47691be78315bb888f984e6cde27f0cf6e982e92880748a88d SHA512 ebf45351cc0d1dc64bbb612766e9915d70d72b057ee787a434bb90f289f6a4f63ab9d4a4be7474d4ffd981217a2250fff3c3580aa7b20256fb242cc4fbd9f624 WHIRLPOOL 503c4fd3d1e782887be14524a8392f56d2e7c314981af3e69dadb160eda009160729f8ad189eb100eb53f9e6af4367e53ecc7c579cbd500c8907c1e454dfd7d7
+DIST ppx_sexp_value-113.33.00.tar.gz 55863 SHA256 c26380a790ce4226a180d69314d284c8d7b093f1874e965d5f90bd66b532d20f SHA512 a13af6addb235b138df6ad021615625133739aaadc254b62efc3951f3259a434614232d60032f969de674652152dc8a67e05a0e6999e1dc6d4504352c5c9a374 WHIRLPOOL 68d82b5aacf3f0682bd82a56361d4d89ef6136c1dd0a9b06b96d49723978f56551a63f143172f69c906e97db93b7e34179a01f9340bac495611f463441badfa6
diff --git a/dev-ml/ppx_sexp_value/ppx_sexp_value-113.33.00.ebuild b/dev-ml/ppx_sexp_value/ppx_sexp_value-113.33.00.ebuild
new file mode 100644
index 000000000000..5d69b0b8e6b8
--- /dev/null
+++ b/dev-ml/ppx_sexp_value/ppx_sexp_value-113.33.00.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit oasis
+
+DESCRIPTION="Standard library for ppx rewriters"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-ml/ppx_tools:=
+ dev-ml/ppx_core:=
+ dev-ml/ppx_driver:=
+ dev-ml/ppx_here:=
+ dev-ml/ppx_sexp_conv:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND} dev-ml/opam"
+
+src_configure() {
+ emake setup.exe
+ OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+}