summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-22 09:36:06 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-03-22 10:19:51 +0100
commit2c4448a65e50d9351d3749402fff0f4f52a9c293 (patch)
treed151223ba593a8908d8e986eaa21e2430a622ca9 /dev-ml
parentnet-im/openfire: bump up to 4.0.2 (diff)
downloadgentoo-2c4448a65e50d9351d3749402fff0f4f52a9c293.tar.gz
gentoo-2c4448a65e50d9351d3749402fff0f4f52a9c293.tar.bz2
gentoo-2c4448a65e50d9351d3749402fff0f4f52a9c293.zip
dev-ml/ocaml-ctypes: bump to 0.5.0
Package-Manager: portage-2.2.28 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-ctypes/Manifest1
-rw-r--r--dev-ml/ocaml-ctypes/ocaml-ctypes-0.5.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-ml/ocaml-ctypes/Manifest b/dev-ml/ocaml-ctypes/Manifest
index 79985b88ff76..e9ff72599103 100644
--- a/dev-ml/ocaml-ctypes/Manifest
+++ b/dev-ml/ocaml-ctypes/Manifest
@@ -1,2 +1,3 @@
DIST ocaml-ctypes-0.4.1.tar.gz 162601 SHA256 74564e049de5d3c0e76ea284c225cb658ac1a2b483345be1efb9be4b3c1702f5 SHA512 8155ffe16a58d5714ceb602afa5531c93526defca39a16047328ac06d2c7c7f52b768b18170391f467e1f6919c69275734faf85d27315e11b8bbefcb1bc8afa9 WHIRLPOOL d8d0ef24e0b6c40f50fddf38fed7238cf95573909d2809cc2ab5c1b9b3dab333210e1ce99cf805804576a79d08d819e2ecdee7b4a6a9e13efb13e7b9f88ad802
DIST ocaml-ctypes-0.4.2.tar.gz 162968 SHA256 704efcbf3b99c180855ad4faed0dd7cec4f2384f9b8963b572329697be8cbae4 SHA512 78e51a4ea35efd6d854b81c65d3e224175927a3c87b9b665d173cefeb3f424e1ed8fc8dfbbb4ce33b4bc43163ecf647ba9b502e69c82eb05ddcde66b8d6c99e4 WHIRLPOOL 124c6f91ae1ae980994f8cca483a2090c60b62864abe8d4b9aac725b2131f331d385a6a1e5b7685e4f61ac4e3e53cb22ac0cad9b32ebefa444d2ef00e15f7caa
+DIST ocaml-ctypes-0.5.0.tar.gz 168414 SHA256 d15df8a065b5b9850400727c0e5cb4eb8ad567c3504278b03065cc766b57bf3e SHA512 0d59b6aec0421e7eb79792bfd02a8f77311bca1787f7b17af0eca4fdaa82a55d27de24bc2c6fa937e3c2b86585cd496d929a7490165e27c49da360e6efd3d67d WHIRLPOOL a84b3d14437cf8a47d09d15a3af67b48ed57a147e09d12f93711102879b2962fbe7b4ea1c327e92da262334bed40d8175c9dd18902f8bc4a19f552b97406fd15
diff --git a/dev-ml/ocaml-ctypes/ocaml-ctypes-0.5.0.ebuild b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.5.0.ebuild
new file mode 100644
index 000000000000..8ebc7be8e1da
--- /dev/null
+++ b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.5.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Library for binding to C libraries using pure OCaml"
+HOMEPAGE="https://github.com/ocamllabs/ocaml-ctypes"
+SRC_URI="https://github.com/ocamllabs/ocaml-ctypes/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.02:=[ocamlopt]
+ virtual/libffi
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ml/ounit )"
+
+src_compile() {
+ emake -j1
+}
+
+src_test() {
+ emake -j1 test
+}
+
+src_install() {
+ findlib_src_install
+ dodoc CHANGES.md README.md
+}