summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-02-23 09:18:28 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-02-23 10:15:49 +0100
commit6f3b8add5ba409c7b9eab96b68d5dbff54c45b7e (patch)
treebad45eff157c3d105aa4e9aae9cc558a8498ff5c /dev-ml
parentdev-ml/logs: Initial import. Ebuild by me. (diff)
downloadgentoo-6f3b8add5ba409c7b9eab96b68d5dbff54c45b7e.tar.gz
gentoo-6f3b8add5ba409c7b9eab96b68d5dbff54c45b7e.tar.bz2
gentoo-6f3b8add5ba409c7b9eab96b68d5dbff54c45b7e.zip
dev-ml/ocaml-conduit: Initial import. Ebuild by me.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-conduit/Manifest1
-rw-r--r--dev-ml/ocaml-conduit/metadata.xml8
-rw-r--r--dev-ml/ocaml-conduit/ocaml-conduit-0.14.5.ebuild46
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-ml/ocaml-conduit/Manifest b/dev-ml/ocaml-conduit/Manifest
new file mode 100644
index 000000000000..56c7c8e077a9
--- /dev/null
+++ b/dev-ml/ocaml-conduit/Manifest
@@ -0,0 +1 @@
+DIST ocaml-conduit-0.14.5.tar.gz 38471 SHA256 00aba333c05866bb712f7890c6f9fd457b85cf592d28adc6636413032683f86f SHA512 c2de6518588e3555cd40dfc6c1ce6d809dc570ddb6a07fb8ccce1797469e9c28ea1a633d4a1b360bf15cdb95e6231ecb0be8bd44e4654baa5268f09519096b52 WHIRLPOOL 5e052d7b9d34d76662496739a6934bf64c1930ca64b2160aa8cbefe0237bd0bb3438a187c3dd05d841b7b475325afcb32bb6fb20e0b61b885c16f4b0b3259aea
diff --git a/dev-ml/ocaml-conduit/metadata.xml b/dev-ml/ocaml-conduit/metadata.xml
new file mode 100644
index 000000000000..ffac4d7ebc01
--- /dev/null
+++ b/dev-ml/ocaml-conduit/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-ml/ocaml-conduit/ocaml-conduit-0.14.5.ebuild b/dev-ml/ocaml-conduit/ocaml-conduit-0.14.5.ebuild
new file mode 100644
index 000000000000..6402be1841e6
--- /dev/null
+++ b/dev-ml/ocaml-conduit/ocaml-conduit-0.14.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Dereference URIs into communication channels for Async or Lwt"
+HOMEPAGE="https://github.com/mirage/ocaml-conduit"
+SRC_URI="https://github.com/mirage/ocaml-conduit/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-lang/ocaml:=
+ dev-ml/sexplib:=
+ dev-ml/stringext:=
+ dev-ml/ocaml-uri:=
+ dev-ml/logs:=
+ dev-ml/ocaml-cstruct:=
+ dev-ml/ocaml-ipaddr:=
+
+ dev-ml/lwt:=
+ dev-ml/async:=
+ dev-ml/ocaml-dns:=
+ dev-ml/ocaml-ssl:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ dev-ml/findlib
+ dev-ml/ocamlbuild
+ dev-ml/ppx_driver
+ dev-ml/ppx_optcomp
+ dev-ml/ppx_sexp_conv
+"
+
+DOCS=( TODO.md README.md CHANGES )
+
+src_install() {
+ findlib_src_preinst
+ default
+}