summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-10-19 12:43:03 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-10-19 12:43:11 +0200
commit8556cc6b4e9ccc7e75a7999eb3577c5395c4e3a2 (patch)
tree16de021beb389b43f4ec46b11640677150de4d7d /dev-ml
parentwww-servers/lighttpd: Version bump, EAPI bump (diff)
downloadgentoo-8556cc6b4e9ccc7e75a7999eb3577c5395c4e3a2.tar.gz
gentoo-8556cc6b4e9ccc7e75a7999eb3577c5395c4e3a2.tar.bz2
gentoo-8556cc6b4e9ccc7e75a7999eb3577c5395c4e3a2.zip
dev-ml/ocaml-containers: bump to 0.20; enable tests
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-containers/Manifest1
-rw-r--r--dev-ml/ocaml-containers/ocaml-containers-0.20.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-ml/ocaml-containers/Manifest b/dev-ml/ocaml-containers/Manifest
index b426f01dc848..5018c9ba475f 100644
--- a/dev-ml/ocaml-containers/Manifest
+++ b/dev-ml/ocaml-containers/Manifest
@@ -1,2 +1,3 @@
DIST ocaml-containers-0.18.tar.gz 418480 SHA256 8bac90113e229a9dc55a2f54c20cf363df43c2e72ca349a5a811ad113a6d2909 SHA512 fa61039fc3bbfcd53117ae582689ffca645b42a811ebe0fc8aa5da93ba5373c2ac54896ecaddbe3eff7593b2be44f208abb625ad3354d2b089a0b811b9f77cff WHIRLPOOL 10795e812baab4525f6fdfbc101c7b14230ef87893ccf01702a6a75e373a12bf643f775f63cb27640f0dd398da541e6c185489dc27cd9fc7bd75a4a90f34baf2
DIST ocaml-containers-0.19.tar.gz 419243 SHA256 e53472e009ea2699f39940844fc0ef9abb332234834c6963f8325aa7df0694f5 SHA512 1ed078121770d72ba685c116ddeebc848b086e371604c7fedf1bdb58ea5cb9685db8a3c7c4edcac69a9cd18ece1eb601d1675c25efe6ab61e2a511a8a857aff2 WHIRLPOOL 27df23c2b0196647f071089d2044dbb7cf4b2c710bdc066eda892e8e4ffe229d5bafc2ec29b5afc4cffd0513d69d16776342258e667e62613ff2c771762ea1d5
+DIST ocaml-containers-0.20.tar.gz 427546 SHA256 d5ffbf6c87bc25b914043817f02a5513fe9b0499d3d0d67b43cceb2bc38d286b SHA512 9e97d4563824a937c42fee89dc86e91ff740bdb4c444ab4ce9b31f50b272f9f400d2d71fb298294d80443002f4b511f2292cc41be15234128bdcd18dd1b1cfd4 WHIRLPOOL f1e0599504d206725a6027905803355e5a80ee936287024bd184062c3030796dd289044e2d6d301bdb104eda25a9d457f424371123f0ce5b320dff1e83463d1f
diff --git a/dev-ml/ocaml-containers/ocaml-containers-0.20.ebuild b/dev-ml/ocaml-containers/ocaml-containers-0.20.ebuild
new file mode 100644
index 000000000000..27d31ce576af
--- /dev/null
+++ b/dev-ml/ocaml-containers/ocaml-containers-0.20.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_TESTS=1
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="A modular standard library focused on data structures"
+HOMEPAGE="https://github.com/c-cube/ocaml-containers"
+SRC_URI="https://github.com/c-cube/ocaml-containers/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ dev-ml/result:=
+ dev-ml/sequence:=
+"
+DEPEND="${RDEPEND} dev-ml/cppo
+ test? ( dev-ml/iTeML )"
+
+src_configure() {
+ oasis_configure_opts="
+ --enable-unix
+ --disable-bench
+ " oasis_src_configure
+}