summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-22 09:37:37 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-03-22 10:19:53 +0100
commitcdd1fb6f2fa7b485f3bae624b89bd86a2357ffa5 (patch)
tree4cb797a646c80c9da1d0871bcf83fe5fa060523d /dev-ml
parentdev-ml/ocaml-ctypes: bump to 0.5.0 (diff)
downloadgentoo-cdd1fb6f2fa7b485f3bae624b89bd86a2357ffa5.tar.gz
gentoo-cdd1fb6f2fa7b485f3bae624b89bd86a2357ffa5.tar.bz2
gentoo-cdd1fb6f2fa7b485f3bae624b89bd86a2357ffa5.zip
dev-ml/typerep_extended: bump to 113.33.00
Package-Manager: portage-2.2.28 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/typerep_extended/Manifest1
-rw-r--r--dev-ml/typerep_extended/typerep_extended-113.33.00.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-ml/typerep_extended/Manifest b/dev-ml/typerep_extended/Manifest
index 6eab85935b9e..9d61297f02cf 100644
--- a/dev-ml/typerep_extended/Manifest
+++ b/dev-ml/typerep_extended/Manifest
@@ -1 +1,2 @@
DIST typerep_extended-113.24.00.tar.gz 117421 SHA256 7c0246e7af1c147b1f00d5a612091bb62e060dc8903f70b8957d5eb2f77b01b8 SHA512 97747967fd3747603ed9fe58b3ddefe0e164dae9237c31d1f9ef719de1b4244afed73f7c29924d24e38d1d0a68fc014f0a87f59910831b6c9fa251dbbd709501 WHIRLPOOL 7734bca0fc1e4591f6e06abd66c05aa5d5f7fd59bd71454f9a2a6ef67888cf65d612aa2297ae25caf7a6e8ad8296f3ac56f5ac827d932cf912bac4f6762dae20
+DIST typerep_extended-113.33.00.tar.gz 117924 SHA256 b104deabc7a387ba4ccf38b5d702a1bfe70b75a9d04218f159c74a76ef3fe74d SHA512 9f7bfc0a5c085ca8537ce9d55ec37f6aec0f657b5b5b43b15378a51f748c36ec39dfeba8cec129ce2658b667f6e05d75b395462058dc5af41f6de387a19aa91a WHIRLPOOL 4cafb60ec3119bb2d30d436ff131af58188be242bbc401b7f896c4f583bd009276345aa1d12c4d1491c9f560e11deb18617d45d4070d713d5e91ce40e77e301b
diff --git a/dev-ml/typerep_extended/typerep_extended-113.33.00.ebuild b/dev-ml/typerep_extended/typerep_extended-113.33.00.ebuild
new file mode 100644
index 000000000000..c2e7488f0cbb
--- /dev/null
+++ b/dev-ml/typerep_extended/typerep_extended-113.33.00.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit oasis
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="Runtime types for OCaml (Extended)"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ >=dev-ml/typerep-112.17.00:=
+ dev-ml/sexplib:=
+ dev-ml/bin-prot:=
+ dev-ml/core_kernel:=
+ dev-ml/ppx_bin_prot:=
+ dev-ml/ppx_driver:=
+ dev-ml/ppx_sexp_conv:=
+ dev-ml/ppx_type_conv:=
+ dev-ml/ppx_typerep_conv:="
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND} dev-ml/opam"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ emake setup.exe
+ OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+ dodoc CHANGES.md
+}