summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Error
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Error')
-rw-r--r--dev-perl/Error/Error-0.170.210.ebuild27
-rw-r--r--dev-perl/Error/Error-0.170.230.ebuild29
-rw-r--r--dev-perl/Error/Error-0.170.240.ebuild29
-rw-r--r--dev-perl/Error/Manifest3
-rw-r--r--dev-perl/Error/metadata.xml12
5 files changed, 100 insertions, 0 deletions
diff --git a/dev-perl/Error/Error-0.170.210.ebuild b/dev-perl/Error/Error-0.170.210.ebuild
new file mode 100644
index 000000000000..9e459c7fba3c
--- /dev/null
+++ b/dev-perl/Error/Error-0.170.210.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=SHLOMIF
+MODULE_VERSION=0.17021
+inherit perl-module
+
+DESCRIPTION="Error/exception handling in an OO-ish way"
+
+LICENSE+=" MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.390.0
+ test? (
+ >=dev-perl/Test-Pod-1.140.0
+ >=dev-perl/Test-Pod-Coverage-1.40.0
+ )
+"
+
+SRC_TEST="do"
diff --git a/dev-perl/Error/Error-0.170.230.ebuild b/dev-perl/Error/Error-0.170.230.ebuild
new file mode 100644
index 000000000000..4ed6d6ec2af7
--- /dev/null
+++ b/dev-perl/Error/Error-0.170.230.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=SHLOMIF
+MODULE_VERSION=0.17023
+inherit perl-module
+
+DESCRIPTION="Error/exception handling in an OO-ish way"
+
+LICENSE+=" MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Scalar-List-Utils
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.280.801
+ test? (
+ >=dev-perl/Test-Pod-1.140.0
+ >=dev-perl/Test-Pod-Coverage-1.40.0
+ )
+"
+
+SRC_TEST="do parallel"
diff --git a/dev-perl/Error/Error-0.170.240.ebuild b/dev-perl/Error/Error-0.170.240.ebuild
new file mode 100644
index 000000000000..10108c24e164
--- /dev/null
+++ b/dev-perl/Error/Error-0.170.240.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=SHLOMIF
+MODULE_VERSION=0.17024
+inherit perl-module
+
+DESCRIPTION="Error/exception handling in an OO-ish way"
+
+LICENSE+=" MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Scalar-List-Utils
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.280.801
+ test? (
+ >=dev-perl/Test-Pod-1.140.0
+ >=dev-perl/Test-Pod-Coverage-1.40.0
+ )
+"
+
+SRC_TEST="do parallel"
diff --git a/dev-perl/Error/Manifest b/dev-perl/Error/Manifest
new file mode 100644
index 000000000000..de5350bde18c
--- /dev/null
+++ b/dev-perl/Error/Manifest
@@ -0,0 +1,3 @@
+DIST Error-0.17021.tar.gz 22400 SHA256 1c81c1b4cdf38ae089f1cd4ae5999e1ea15bbba3d259085acf829fb9874e760d SHA512 7efd445b03e17d254a17cb1e6fb4db7d3674e9d5bc67fa075282318da8a4820dcba5ee1120b8be11a7fe27da211f97c3cae990733a9a9a7bb965b6d28ab87f10 WHIRLPOOL 32c3299d5e89e35261dcc9f7425f995d18c98194696c2090b566748d660311aec070dd21436332381287d9b0d98bf7ec7477dd2f088234b006efe82bf60acf9e
+DIST Error-0.17023.tar.gz 31038 SHA256 af48e19077d8837c6377d8a9ba2ce473c100caf5eeb7b53606c3f78a0e8b5d37 SHA512 478a18b4a9735612e1af0ba221a2c082f3522ffeb2d593e8f1bf963e5f9a4d67fc913de5bdf18d4255b1fe69f2d300fbb2a9f25ad5cf17f1b8e4932c765cc924 WHIRLPOOL 40f10ab10a7dcf5242f26379f0d318bb4a8193b88e9973c1acc962f56b1dfd5a48a38a9ff03a0ccb9c3691b9e17a9c6e27440447276f944f7ba607239e328140
+DIST Error-0.17024.tar.gz 31269 SHA256 074db7c783a67b0667eca64a4f6a0c3de94998afc92c01d6453163eb04b9150d SHA512 886ad8d527936ddca564c466bb753e29bcb203ebc32bee7c8af8db05f70fcae17d3536f1f0163d17e3d1a0669da0c559ea0e5d14a1e83c4c7e329d4368ba3e77 WHIRLPOOL e860b7bc705c155787ac1c3231d1b952969790c01d7d2d9aac18ae9684cb8a3a28d6115afe2b14940b797a4da9df49819c9c78044598cf3af0a342825bd4e829
diff --git a/dev-perl/Error/metadata.xml b/dev-perl/Error/metadata.xml
new file mode 100644
index 000000000000..a96e01256d1a
--- /dev/null
+++ b/dev-perl/Error/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Error</remote-id>
+ <remote-id type="cpan-module">Error</remote-id>
+ <remote-id type="cpan-module">Error::Simple</remote-id>
+ <remote-id type="cpan-module">Error::WarnDie</remote-id>
+ <remote-id type="cpan-module">Error::subs</remote-id>
+ </upstream>
+</pkgmetadata>