summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2015-11-27 01:05:11 +0000
committerPatrice Clement <monsieurp@gentoo.org>2015-11-27 01:15:41 +0000
commitd5346eb86692994b0280dab94c96801711cd2cfa (patch)
tree1e52b94c94ca1de6fab865ecb1e9894445cbc63d /dev-perl/Module-Pluggable/Module-Pluggable-5.200.0.ebuild
parentdev-perl/Module-Locate: Version bump. (diff)
downloadgentoo-d5346eb86692994b0280dab94c96801711cd2cfa.tar.gz
gentoo-d5346eb86692994b0280dab94c96801711cd2cfa.tar.bz2
gentoo-d5346eb86692994b0280dab94c96801711cd2cfa.zip
dev-perl/Module-Pluggable: Version bump.
Package-Manager: portage-2.2.20.1 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-perl/Module-Pluggable/Module-Pluggable-5.200.0.ebuild')
-rw-r--r--dev-perl/Module-Pluggable/Module-Pluggable-5.200.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-perl/Module-Pluggable/Module-Pluggable-5.200.0.ebuild b/dev-perl/Module-Pluggable/Module-Pluggable-5.200.0.ebuild
new file mode 100644
index 000000000000..3e25ec16281b
--- /dev/null
+++ b/dev-perl/Module-Pluggable/Module-Pluggable-5.200.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=SIMONW
+MODULE_VERSION=5.2
+inherit perl-module
+
+DESCRIPTION="Automatically give your module the ability to have plugins"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ >=virtual/perl-File-Spec-3
+ virtual/perl-if
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.380.0
+ test? ( >=virtual/perl-Test-Simple-0.620.0 )
+"
+
+SRC_TEST="do parallel"