summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-06-16 13:42:13 +1200
committerKent Fredric <kentnl@gentoo.org>2017-06-17 00:28:04 +1200
commit4c4346b0e122b7684040b0cb11091cc003eb9777 (patch)
tree811f1862e95d725bf06f350aba2c1ec12db20d38 /dev-perl/WWW-Curl
parentprofiles/arch/arm64: mask neon on pixman, it seems armv7 only. (diff)
downloadgentoo-4c4346b0e122b7684040b0cb11091cc003eb9777.tar.gz
gentoo-4c4346b0e122b7684040b0cb11091cc003eb9777.tar.bz2
gentoo-4c4346b0e122b7684040b0cb11091cc003eb9777.zip
dev-perl/WWW-Curl: Fix for '.' in @INC
Generic Module::Install fix for Perl 5.26 Bug: https://rt.cpan.org/Ticket/Display.html?id=122110 Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-perl/WWW-Curl')
-rw-r--r--dev-perl/WWW-Curl/WWW-Curl-4.170.0.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/dev-perl/WWW-Curl/WWW-Curl-4.170.0.ebuild b/dev-perl/WWW-Curl/WWW-Curl-4.170.0.ebuild
index 004373746620..8a61bc797f13 100644
--- a/dev-perl/WWW-Curl/WWW-Curl-4.170.0.ebuild
+++ b/dev-perl/WWW-Curl/WWW-Curl-4.170.0.ebuild
@@ -20,3 +20,9 @@ DEPEND="${RDEPEND}"
SRC_TEST=online
PATCHES=("${FILESDIR}"/${PN}-4.150.0-curl-7.50.2.patch)
+
+src_prepare() {
+ sed -i -e 's/use inc::Module::Install;/use lib q[.]; use inc::Module::Install;/' Makefile.PL ||
+ die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+ perl-module_src_prepare
+}