summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2017-07-15 07:13:45 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2017-07-15 07:13:45 -0400
commit89d0e9b74f73355e0b26187db60c1f1d182494cc (patch)
tree6e29e601919f2d57f7acffd46ac5ca8407fc2a27 /dev-perl
parentmedia-libs/harfbuzz-1.4.6-r2: add amd64 keyword (diff)
downloadgentoo-89d0e9b74f73355e0b26187db60c1f1d182494cc.tar.gz
gentoo-89d0e9b74f73355e0b26187db60c1f1d182494cc.tar.bz2
gentoo-89d0e9b74f73355e0b26187db60c1f1d182494cc.zip
dev-perl/DBD-Pg: Version Bump to 3.6.2
Version bump enables building against >=dev-db/postgresql-10. Bugs: 624974 Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/DBD-Pg/DBD-Pg-3.6.2.ebuild44
-rw-r--r--dev-perl/DBD-Pg/Manifest1
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-perl/DBD-Pg/DBD-Pg-3.6.2.ebuild b/dev-perl/DBD-Pg/DBD-Pg-3.6.2.ebuild
new file mode 100644
index 000000000000..da68ebc2ce4d
--- /dev/null
+++ b/dev-perl/DBD-Pg/DBD-Pg-3.6.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=TURNSTEP
+inherit perl-module
+
+DESCRIPTION="PostgreSQL database driver for the DBI module"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="
+ virtual/perl-version
+ >=dev-perl/DBI-1.614.0
+ dev-db/postgresql:*
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+
+# testcases require a local database with an
+# open password for the postgres user.
+DIST_TEST="skip"
+
+src_prepare() {
+ postgres_include="$(readlink -f "${EPREFIX}"/usr/include/postgresql)"
+ postgres_lib="${postgres_include//include/lib}"
+ # Fall-through case is the non-split postgresql
+ # The active cases instead get us the matching libdir for the includedir.
+ for i in lib lib64 ; do
+ if [ -d "${postgres_lib}/${i}" ]; then
+ postgres_lib="${postgres_lib}/${i}"
+ break
+ fi
+ done
+
+ # env variables for compilation:
+ export POSTGRES_INCLUDE="${postgres_include}"
+ export POSTGRES_LIB="${postgres_lib}"
+ perl-module_src_prepare
+}
diff --git a/dev-perl/DBD-Pg/Manifest b/dev-perl/DBD-Pg/Manifest
index 7a9805e758fe..0d26187baeec 100644
--- a/dev-perl/DBD-Pg/Manifest
+++ b/dev-perl/DBD-Pg/Manifest
@@ -1 +1,2 @@
DIST DBD-Pg-3.5.3.tar.gz 256570 SHA256 7e98a9b975256a4733db1c0e974cad5ad5cb821489323e395ed97bd058e0a90e SHA512 7a564e5c86fa41719289f6e391f0cd39f01df7d088892fca11175c60fec8a3af884f9204ae834caac2024ff0d45dcc013e314ec0c09a07fe7ee76170ec3a634f WHIRLPOOL 6f4091284c2c91b8c2126e06a2727b65e672db91ce5f265841ef3c02b977f48712e84ad013980bbe4a2e127f5003906bf315d7b6a86787440a9cc6688aa14cd8
+DIST DBD-Pg-3.6.2.tar.gz 258640 SHA256 4b1d2edea07cfaadbb710ac138f41346752bb62f5d29cd0363f11cb4f7c3c4ae SHA512 1f55bd463d90cd0d9933acde0a79462a57f11e7ed9519943cc2cb4487b4b69edd7d16ffa3d666c50aca797f9756ff4e6a0d67b58bc100f4920da36169d73b7b4 WHIRLPOOL 8d28fe8f64b952f57ede925d20a88aca1631462e85b59112ddf073753892053fd59b4802d293fdd745a1c047ff436bb7192b5cf5839436c5d288d4b1b403bc73