summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2015-12-02 14:14:08 -0500
committerBrian Evans <grknight@gentoo.org>2015-12-02 14:14:08 -0500
commitb4633c8335eb41a6294f01d2a19c31596277729e (patch)
tree3724a2537e67a43675ae2b03b161b6e3bd7cec8d /dev-php/pecl-apcu/pecl-apcu-4.0.8.ebuild
parentapp-shells/bash: do not leave exit value non-zero in default profile script (diff)
downloadgentoo-b4633c8335eb41a6294f01d2a19c31596277729e.tar.gz
gentoo-b4633c8335eb41a6294f01d2a19c31596277729e.tar.bz2
gentoo-b4633c8335eb41a6294f01d2a19c31596277729e.zip
dev-php/pecl-apcu: Version bump
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-php/pecl-apcu/pecl-apcu-4.0.8.ebuild')
-rw-r--r--dev-php/pecl-apcu/pecl-apcu-4.0.8.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/dev-php/pecl-apcu/pecl-apcu-4.0.8.ebuild b/dev-php/pecl-apcu/pecl-apcu-4.0.8.ebuild
new file mode 100644
index 000000000000..2289285f9b1e
--- /dev/null
+++ b/dev-php/pecl-apcu/pecl-apcu-4.0.8.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PHP_EXT_NAME="apcu"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="NOTICE README.md TECHNOTES.txt TODO"
+
+USE_PHP="php5-6 php5-5"
+
+S="${WORKDIR}/apcu-${PV}"
+PHP_EXT_S="${WORKDIR}/apcu-${PV}"
+
+inherit php-ext-pecl-r2 confutils eutils
+
+S="${WORKDIR}/apcu-${PV}"
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Stripped down version of APC supporting only user cache"
+LICENSE="PHP-3.01"
+SLOT="0"
+IUSE="+mmap"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+LOCKS="pthreadmutex pthreadrw spinlock semaphore"
+
+LUSE=""
+for l in ${LOCKS}; do
+ LUSE+="lock_${l} "
+done
+
+IUSE+=" ${LUSE/lock_pthreadrw/+lock_pthreadrw}"
+
+REQUIRED_USE="^^ ( $LUSE )"
+
+src_configure() {
+ my_conf="--enable-apcu"
+ use mmap || my_conf+=" --disable-apcu-mmap"
+
+ enable_extension_enable "apcu-rwlocks" "lock_pthreadrw" 0
+
+ php-ext-source-r2_src_configure
+}
+
+src_install() {
+ php-ext-pecl-r2_src_install
+
+ dodir "${PHP_EXT_SHARED_DIR}"
+ insinto "${PHP_EXT_SHARED_DIR}"
+ doins apc.php
+}
+
+pkg_postinst() {
+ elog "The apc.php file shipped with this release of pecl-apcu was"
+ elog "installed into ${PHP_EXT_SHARED_DIR}/."
+}