summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2016-06-23 16:02:40 -0400
committerBrian Evans <grknight@gentoo.org>2016-06-23 16:04:42 -0400
commitaf90b6c10c91c005459c57e5ba9c0170781effac (patch)
tree246e4bdf2bb39faeaa62f00a1708e897e13bec6d /dev-php/pecl-apcu/pecl-apcu-5.1.5.ebuild
parentprofiles/updates/2Q-2016: slot move >=pecl-apcu-5 to allow php5 and php7 inst... (diff)
downloadgentoo-af90b6c10c91c005459c57e5ba9c0170781effac.tar.gz
gentoo-af90b6c10c91c005459c57e5ba9c0170781effac.tar.bz2
gentoo-af90b6c10c91c005459c57e5ba9c0170781effac.zip
dev-php/pecl-apcu: Version bump to new slot
This version allows both apcu to install to 5.6 and 7.0 Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-php/pecl-apcu/pecl-apcu-5.1.5.ebuild')
-rw-r--r--dev-php/pecl-apcu/pecl-apcu-5.1.5.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/dev-php/pecl-apcu/pecl-apcu-5.1.5.ebuild b/dev-php/pecl-apcu/pecl-apcu-5.1.5.ebuild
new file mode 100644
index 00000000000..6202e0f046b
--- /dev/null
+++ b/dev-php/pecl-apcu/pecl-apcu-5.1.5.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PHP_EXT_NAME="apcu"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="NOTICE README.md TECHNOTES.txt TODO"
+
+# Define 5.6 here so we get the USE and REQUIRED_USE from the eclass
+# This allows us to depend on the other slot
+USE_PHP="php5-6 php7-0"
+
+inherit php-ext-pecl-r2 confutils
+
+# However, we only really build for 7.0; so redefine it here
+USE_PHP="php7-0"
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Stripped down version of APC supporting only user cache"
+LICENSE="PHP-3.01"
+SLOT="7"
+IUSE="+mmap"
+
+DEPEND=""
+RDEPEND="${DEPEND} php_targets_php5-6? ( dev-php/pecl-apcu:0[php_targets_php5-6] )"
+
+LOCKS="pthreadmutex pthreadrw spinlock semaphore"
+
+LUSE=""
+for l in ${LOCKS}; do
+ LUSE+="lock_${l} "
+done
+
+IUSE+=" ${LUSE/lock_pthreadrw/+lock_pthreadrw}"
+
+REQUIRED_USE="^^ ( $LUSE )"
+
+src_configure() {
+ my_conf="--enable-apcu"
+ use mmap || my_conf+=" --disable-apcu-mmap"
+
+ enable_extension_enable "apcu-rwlocks" "lock_pthreadrw" 0
+
+ php-ext-source-r2_src_configure
+}
+
+src_install() {
+ if use php_targets_php7-0 ; then
+ php-ext-pecl-r2_src_install
+
+ insinto /usr/share/php7/apcu
+ doins apc.php
+ fi
+}
+
+pkg_postinst() {
+ if use php_targets_php7-0 ; then
+ elog "The apc.php file shipped with this release of pecl-apcu was"
+ elog "installed into ${EPREFIX}/usr/share/php7/apcu/."
+ elog
+ elog "If you depend on the apc_* functions,"
+ elog "please install dev-php/pecl-apcu_bc as this extension no longer"
+ elog "provides backwards compatibility."
+ fi
+}