summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2016-12-08 14:44:43 -0500
committerBrian Evans <grknight@gentoo.org>2016-12-08 15:05:54 -0500
commit8e64c249f0de288d0800f694e833a857f8dc3b90 (patch)
treeafd4113a2ee02ce07d2f9a9eb6ff247208997417 /dev-php/pecl-crack
parentapp-admin/ansible: add 2.2.1.0_rc1 for testing (diff)
downloadgentoo-8e64c249f0de288d0800f694e833a857f8dc3b90.tar.gz
gentoo-8e64c249f0de288d0800f694e833a857f8dc3b90.tar.bz2
gentoo-8e64c249f0de288d0800f694e833a857f8dc3b90.zip
dev-php/pecl-crack: Revbump to drop php 5.4 and 5.5 dependencies
This package has not been ported and fails with PHP 7.0. Patches are welcome, but this package is in danger of being dropped when PHP 5.6 becomes obsolete. Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-php/pecl-crack')
-rw-r--r--dev-php/pecl-crack/files/fix-php-5-4-support.patch4
-rw-r--r--dev-php/pecl-crack/pecl-crack-0.4-r5.ebuild25
2 files changed, 27 insertions, 2 deletions
diff --git a/dev-php/pecl-crack/files/fix-php-5-4-support.patch b/dev-php/pecl-crack/files/fix-php-5-4-support.patch
index 4709ad8dd116..7fddadfabbbd 100644
--- a/dev-php/pecl-crack/files/fix-php-5-4-support.patch
+++ b/dev-php/pecl-crack/files/fix-php-5-4-support.patch
@@ -1,8 +1,8 @@
Gentoo bug: 423869
Thanks to hanno
---- pecl/crack/trunk/crack.c 2008/07/17 10:02:47 262854
-+++ pecl/crack/trunk/crack.c 2012/06/07 16:13:34 326013
+--- a/crack.c 2008/07/17 10:02:47 262854
++++ b/crack.c 2012/06/07 16:13:34 326013
@@ -38,7 +38,7 @@
/* {{{ crack_functions[]
diff --git a/dev-php/pecl-crack/pecl-crack-0.4-r5.ebuild b/dev-php/pecl-crack/pecl-crack-0.4-r5.ebuild
new file mode 100644
index 000000000000..7ab7d268a550
--- /dev/null
+++ b/dev-php/pecl-crack/pecl-crack-0.4-r5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PHP_EXT_NAME="crack"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+PHP_EXT_EXTRA_ECONF=""
+DOCS=( EXPERIMENTAL )
+
+USE_PHP="php5-6"
+
+inherit php-ext-pecl-r3
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+DESCRIPTION="PHP interface to the cracklib libraries"
+LICENSE="PHP-3 CRACKLIB"
+SLOT="0"
+IUSE=""
+# Patch for http://pecl.php.net/bugs/bug.php?id=5765
+PATCHES=( "${FILESDIR}/fix-php-5-4-support.patch"
+"${FILESDIR}/fix-pecl-bug-5765.patch" )