summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Levitsky <kitsunenokenja@protonmail.ch>2018-01-08 21:22:52 -0500
committerMichael Orlitzky <mjo@gentoo.org>2018-02-14 12:32:42 -0500
commitee86c6c433ff0523a1b7e8ad614e94bc0205d790 (patch)
treeb1ba67a86815e248436bf75f3047471aa6f6e3b9 /dev-php/phar-io-manifest
parentapp-admin/syslog-ng: amd64 stable (diff)
downloadgentoo-ee86c6c433ff0523a1b7e8ad614e94bc0205d790.tar.gz
gentoo-ee86c6c433ff0523a1b7e8ad614e94bc0205d790.tar.bz2
gentoo-ee86c6c433ff0523a1b7e8ad614e94bc0205d790.zip
dev-php/phar-io-manifest: new package
Package-Manager: Portage-2.3.13, Repoman-2.3.3 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'dev-php/phar-io-manifest')
-rw-r--r--dev-php/phar-io-manifest/Manifest1
-rw-r--r--dev-php/phar-io-manifest/files/autoload.php62
-rw-r--r--dev-php/phar-io-manifest/metadata.xml11
-rw-r--r--dev-php/phar-io-manifest/phar-io-manifest-1.0.1.ebuild28
4 files changed, 102 insertions, 0 deletions
diff --git a/dev-php/phar-io-manifest/Manifest b/dev-php/phar-io-manifest/Manifest
new file mode 100644
index 000000000000..f78f8aa5b7e9
--- /dev/null
+++ b/dev-php/phar-io-manifest/Manifest
@@ -0,0 +1 @@
+DIST phar-io-manifest-1.0.1.tar.gz 21403 BLAKE2B 0f18d94d127ec54914cb60756fd3e75c2d13ec593b7101735e385e4515abf4da0f03ef94d0bbbfaee02f348309525504f5e99e150a68b0d0fcd2129ccade4541 SHA512 3e4dd7ddd6de0a9f70595d0d8a6721782d2584526d3d4649cf0338ab36f106798daf4b7dcbf5bd972893a1569b622e4217212e5812b14e4bf3f698504f4d2228
diff --git a/dev-php/phar-io-manifest/files/autoload.php b/dev-php/phar-io-manifest/files/autoload.php
new file mode 100644
index 000000000000..256ec39e5b84
--- /dev/null
+++ b/dev-php/phar-io-manifest/files/autoload.php
@@ -0,0 +1,62 @@
+<?php
+/* Autoloader for dev-php/phar-io-manifest */
+require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
+
+\Fedora\Autoloader\Autoload::addClassMap(
+ [
+ 'phario\\manifest\\manifestdocumentmapper' => '/ManifestDocumentMapper.php',
+ 'phario\\manifest\\manifestloader' => '/ManifestLoader.php',
+ 'phario\\manifest\\manifestserializer' => '/ManifestSerializer.php',
+ 'phario\\manifest\\exception' => '/exceptions/Exception.php',
+ 'phario\\manifest\\invalidapplicationnameexception' => '/exceptions/InvalidApplicationNameException.php',
+ 'phario\\manifest\\invalidemailexception' => '/exceptions/InvalidEmailException.php',
+ 'phario\\manifest\\invalidurlexception' => '/exceptions/InvalidUrlException.php',
+ 'phario\\manifest\\manifestdocumentexception' => '/exceptions/ManifestDocumentException.php',
+ 'phario\\manifest\\manifestdocumentmapperexception' => '/exceptions/ManifestDocumentMapperException.php',
+ 'phario\\manifest\\manifestelementexception' => '/exceptions/ManifestElementException.php',
+ 'phario\\manifest\\manifestloaderexception' => '/exceptions/ManifestLoaderException.php',
+ 'phario\\manifest\\application' => '/values/Application.php',
+ 'phario\\manifest\\applicationname' => '/values/ApplicationName.php',
+ 'phario\\manifest\\author' => '/values/Author.php',
+ 'phario\\manifest\\authorcollection' => '/values/AuthorCollection.php',
+ 'phario\\manifest\\authorcollectioniterator' => '/values/AuthorCollectionIterator.php',
+ 'phario\\manifest\\bundledcomponent' => '/values/BundledComponent.php',
+ 'phario\\manifest\\bundledcomponentcollection' => '/values/BundledComponentCollection.php',
+ 'phario\\manifest\\bundledcomponentcollectioniterator' => '/values/BundledComponentCollectionIterator.php',
+ 'phario\\manifest\\copyrightinformation' => '/values/CopyrightInformation.php',
+ 'phario\\manifest\\email' => '/values/Email.php',
+ 'phario\\manifest\\extension' => '/values/Extension.php',
+ 'phario\\manifest\\library' => '/values/Library.php',
+ 'phario\\manifest\\license' => '/values/License.php',
+ 'phario\\manifest\\manifest' => '/values/Manifest.php',
+ 'phario\\manifest\\phpextensionrequirement' => '/values/PhpExtensionRequirement.php',
+ 'phario\\manifest\\phpversionrequirement' => '/values/PhpVersionRequirement.php',
+ 'phario\\manifest\\requirement' => '/values/Requirement.php',
+ 'phario\\manifest\\requirementcollection' => '/values/RequirementCollection.php',
+ 'phario\\manifest\\requirementcollectioniterator' => '/values/RequirementCollectionIterator.php',
+ 'phario\\manifest\\type' => '/values/Type.php',
+ 'phario\\manifest\\url' => '/values/Url.php',
+ 'phario\\manifest\\authorelement' => '/xml/AuthorElement.php',
+ 'phario\\manifest\\authorelementcollection' => '/xml/AuthorElementCollection.php',
+ 'phario\\manifest\\bundleselement' => '/xml/BundlesElement.php',
+ 'phario\\manifest\\componentelement' => '/xml/ComponentElement.php',
+ 'phario\\manifest\\componentelementcollection' => '/xml/ComponentElementCollection.php',
+ 'phario\\manifest\\containselement' => '/xml/ContainsElement.php',
+ 'phario\\manifest\\copyrightelement' => '/xml/CopyrightElement.php',
+ 'phario\\manifest\\elementcollection' => '/xml/ElementCollection.php',
+ 'phario\\manifest\\extelement' => '/xml/ExtElement.php',
+ 'phario\\manifest\\extelementcollection' => '/xml/ExtElementCollection.php',
+ 'phario\\manifest\\extensionelement' => '/xml/ExtensionElement.php',
+ 'phario\\manifest\\licenseelement' => '/xml/LicenseElement.php',
+ 'phario\\manifest\\manifestdocument' => '/xml/ManifestDocument.php',
+ 'phario\\manifest\\manifestdocumentloadingexception' => '/xml/ManifestDocumentLoadingException.php',
+ 'phario\\manifest\\manifestelement' => '/xml/ManifestElement.php',
+ 'phario\\manifest\\phpelement' => '/xml/PhpElement.php',
+ 'phario\\manifest\\requireselement' => '/xml/RequiresElement.php',
+ ],
+ __DIR__
+);
+
+\Fedora\Autoloader\Dependencies::required([
+ '/usr/share/php/PharIo/Version/autoload.php'
+]);
diff --git a/dev-php/phar-io-manifest/metadata.xml b/dev-php/phar-io-manifest/metadata.xml
new file mode 100644
index 000000000000..622fae9de476
--- /dev/null
+++ b/dev-php/phar-io-manifest/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">phar-io/manifest</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-php/phar-io-manifest/phar-io-manifest-1.0.1.ebuild b/dev-php/phar-io-manifest/phar-io-manifest-1.0.1.ebuild
new file mode 100644
index 000000000000..a9bec3adf3c4
--- /dev/null
+++ b/dev-php/phar-io-manifest/phar-io-manifest-1.0.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="manifest"
+
+DESCRIPTION="Component for reading phar.io manifest information from a PHP Archive (PHAR)"
+HOMEPAGE="https://github.com/phar-io/manifest"
+SRC_URI="https://github.com/phar-io/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ >=dev-php/phar-io-version-1.0.1
+ >=dev-lang/php-5.6[phar]"
+
+src_install() {
+ insinto /usr/share/php/PharIo/Manifest
+ doins -r src/*
+ doins "${FILESDIR}/autoload.php"
+ dodoc README.md
+}