summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2016-03-01 19:51:46 -0500
committerBrian Evans <grknight@gentoo.org>2016-03-01 19:51:46 -0500
commit9318436195bf44c057e267060fd3fbac269d5100 (patch)
tree099e5ff571aaa29cbce3f984258cd0e9f0f42798 /dev-php/xdebug
parentdev-php/xdebug-client: Version bump; also bump to EAPI=6 (diff)
downloadgentoo-9318436195bf44c057e267060fd3fbac269d5100.tar.gz
gentoo-9318436195bf44c057e267060fd3fbac269d5100.tar.bz2
gentoo-9318436195bf44c057e267060fd3fbac269d5100.zip
dev-php/xdebug: Version bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-php/xdebug')
-rw-r--r--dev-php/xdebug/Manifest1
-rw-r--r--dev-php/xdebug/xdebug-2.4.0_rc4.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/dev-php/xdebug/Manifest b/dev-php/xdebug/Manifest
index f2184ec9cc3f..b42ac2890aad 100644
--- a/dev-php/xdebug/Manifest
+++ b/dev-php/xdebug/Manifest
@@ -3,4 +3,5 @@ DIST xdebug-2.2.7.tgz 256437 SHA256 4fce7fc794ccbb1dd0b961191cd0323516e216502fe7
DIST xdebug-2.3.1.tgz 266218 SHA256 b50365896089c76d6d64924b66428cc5ef6b4802371e3d422581b3c34d3ca64c SHA512 aca3ce1546f8b99482f55c0f09e532addecff7db4cc81818260b2d3524fd6888e05c15ed0f98f25a139c40e011540705f02aab56f4c52d90212a843459493bd2 WHIRLPOOL 69e4545c1489f240a23ba4ee70afec754471e5cbffdd48a1d5f5db1eace13982807b1e30ae2efd541f79b658613e770ad2dea1ca016a67037e5b5b59ce08fb9c
DIST xdebug-2.3.3.tgz 268381 SHA256 b27bd09b23136d242dbc94f4503c98f012a521d5597002c9d463a63c6b0cdfe3 SHA512 212604e87caa67b3734befa0f57580532b0edd346ed871bbaba72ba8319ba60eb8d66649cb5716df250f28ef1cd2384ccc6f651b90ab4936dbcb45ef6c5f7438 WHIRLPOOL f228a2527dc9f2a166bdd4f2920537d5bc66e00f528f21ca05b7038ca535fb3011f3f39a39871c5ac0a62d46d3c3f3eb4a76d33e9c33c79b633be252e89af23e
DIST xdebug-2.4.0RC2.tgz 263506 SHA256 d09bf890f50178d083291288d9dea34a90a95bd8e9cbc9755d14a8e7ebe9d6d0 SHA512 fa719d13e13a912c7425318f31fb0baa9440b8d52dbaed7fff43afcec98b0c0fd3ead627bed1c31c4dd1b41315f76cec093fd5521ad657cf5514afa5eb284d67 WHIRLPOOL 107978033e15b11e9a708a2042cf6debeeee2a4785dc45cd69381dce5adde9b41e1203511a56cf1d32f211bec11f4d8bb9d2589dbab1a2f839ee3d30abb48456
+DIST xdebug-2.4.0RC4.tgz 264477 SHA256 55f8c906d8e7413c872e91db599082f18c3e49c736adf977333cd313fae635e8 SHA512 facab7b65393c1e4a84144f0e2be31b5cd42421b0f43e3bd6ccb0c1d73e63cba75e3131c901e5ebef7cd46252fb86f31d06064d77694411b4a4397abde170883 WHIRLPOOL cac678bb8c1ffa274e1b3e6f766722d6554d7415640b2dae53e050c72cc48a0032312e576f1ee0c9d3e6a916f759a53dda54a119007b0189712ba74ecc793d65
DIST xdebug-2.4.0beta1.tgz 269305 SHA256 7936814fff7cae80bdf4106e9cc9e7c350d236f5a58a1d6ddd28d1829ae99acf SHA512 8d0e9ae9544f930c965e06713a89e5f0e64b43aaa78055805541641106b136c7ff1d1bd675e671147e32fbec0d4c45f0efed9676486dd89fb287f97f75d75464 WHIRLPOOL 955e24a2f27313ffc4765eeb2d6dc67ef6ed77cb2f337e650566ec357334db24ab31cb100cbee1fef45bda3b183e92a656b9014b6b60f8b17b6168f7311d6a7d
diff --git a/dev-php/xdebug/xdebug-2.4.0_rc4.ebuild b/dev-php/xdebug/xdebug-2.4.0_rc4.ebuild
new file mode 100644
index 000000000000..008c592142d1
--- /dev/null
+++ b/dev-php/xdebug/xdebug-2.4.0_rc4.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PHP_EXT_NAME="xdebug"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="yes"
+
+USE_PHP="php7-0 php5-6 php5-5"
+
+MY_PV="${PV/_/}"
+MY_PV="${MY_PV/rc/RC}"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+inherit php-ext-source-r2
+
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+
+DESCRIPTION="A PHP debugging and profiling extension"
+HOMEPAGE="http://www.xdebug.org/"
+SRC_URI="http://pecl.php.net/get/${PN}-${MY_PV}.tgz"
+LICENSE="Xdebug"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ ~dev-php/xdebug-client-${PV}"
+
+src_install() {
+ dodoc README.rst CREDITS
+ php-ext-source-r2_src_install
+
+ php-ext-source-r2_addtoinifiles "xdebug.auto_trace" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.trace_output_dir" '"/tmp"'
+ php-ext-source-r2_addtoinifiles "xdebug.trace_output_name" '"trace.%c"'
+ php-ext-source-r2_addtoinifiles "xdebug.trace_format" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.trace_options" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.collect_includes" '"1"'
+ php-ext-source-r2_addtoinifiles "xdebug.collect_params" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.collect_return" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.collect_vars" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.default_enable" '"1"'
+ php-ext-source-r2_addtoinifiles "xdebug.extended_info" '"1"'
+ php-ext-source-r2_addtoinifiles "xdebug.manual_url" '"http://www.php.net"'
+ php-ext-source-r2_addtoinifiles "xdebug.max_nesting_level" '"100"'
+ php-ext-source-r2_addtoinifiles "xdebug.show_exception_trace" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.show_local_vars" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.show_mem_delta" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump.COOKIE" '"NULL"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump.ENV" '"NULL"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump.FILES" '"NULL"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump.GET" '"NULL"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump.POST" '"NULL"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump.REQUEST" '"NULL"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump.SERVER" '"NULL"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump.SESSION" '"NULL"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump_globals" '"1"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump_once" '"1"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump_undefined" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.profiler_enable" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.profiler_output_dir" '"/tmp"'
+ php-ext-source-r2_addtoinifiles "xdebug.profiler_output_name" '"cachegrind.out.%p"'
+ php-ext-source-r2_addtoinifiles "xdebug.profiler_enable_trigger" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.profiler_append" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.profiler_aggregate" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.remote_enable" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.remote_handler" '"dbgp"'
+ php-ext-source-r2_addtoinifiles "xdebug.remote_host" '"localhost"'
+ php-ext-source-r2_addtoinifiles "xdebug.remote_mode" '"req"'
+ php-ext-source-r2_addtoinifiles "xdebug.remote_port" '"9000"'
+ php-ext-source-r2_addtoinifiles "xdebug.remote_autostart" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.remote_log" '""'
+ php-ext-source-r2_addtoinifiles "xdebug.idekey" '""'
+ php-ext-source-r2_addtoinifiles "xdebug.var_display_max_data" '"512"'
+ php-ext-source-r2_addtoinifiles "xdebug.var_display_max_depth" '"2"'
+ php-ext-source-r2_addtoinifiles "xdebug.var_display_max_children" '"128"'
+
+}
+
+pkg_postinst() {
+ ewarn "We have set xdebug.default_enable to 0 (off), as xdebug can be"
+ ewarn "installed as a dependency, and not all users will want xdebug to be"
+ ewarn "enabled by default. If you want to enable it, you should edit the"
+ ewarn "ini file and set xdebug.default_enable to 1. Alternatively you can"
+ ewarn "call xdebug_enable() in your code."
+}