summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2015-11-06 11:26:31 -0500
committerBrian Evans <grknight@gentoo.org>2015-11-06 11:31:51 -0500
commit033373f4e4e4606135d307376caf356a178b0dda (patch)
treeec55f823b920eb7241c62a162cfc0394f04f4f95 /dev-php
parentdev-php/xdebug-client: Version bumps for 2.3.3 and 2.4.0beta1 (diff)
downloadgentoo-033373f4e4e4606135d307376caf356a178b0dda.tar.gz
gentoo-033373f4e4e4606135d307376caf356a178b0dda.tar.bz2
gentoo-033373f4e4e4606135d307376caf356a178b0dda.zip
dev-php/xdebug: Version bumps for 2.3.3 and 2.4.0beta1
Package-Manager: portage-2.2.23
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/xdebug/Manifest2
-rw-r--r--dev-php/xdebug/xdebug-2.3.3.ebuild89
-rw-r--r--dev-php/xdebug/xdebug-2.4.0_beta1.ebuild89
3 files changed, 180 insertions, 0 deletions
diff --git a/dev-php/xdebug/Manifest b/dev-php/xdebug/Manifest
index 534b41c35ad0..a4d359970e80 100644
--- a/dev-php/xdebug/Manifest
+++ b/dev-php/xdebug/Manifest
@@ -1,3 +1,5 @@
DIST xdebug-2.2.6.tgz 256161 SHA256 6dd1cba0605e75009331aa3625a19ef49ade5a75aa9fe2ff8a818108d2cce84e SHA512 18deac94f8f9c102dce83ed1accd0831e5b8c2f5d47ea60f89c8b493e5e180d0dfa153065089e1081276db8960ff2ea4082103f228f9191c572888180efa6f82 WHIRLPOOL 0e152ea5740bc8ca8cc6d0178bb59556f98ba0722a0b3cdaeecdc5aa551324cadf5f1c11b215058cf890c16eb7e9e108919a389a6c89d60a469396a20cc083ed
DIST xdebug-2.2.7.tgz 256437 SHA256 4fce7fc794ccbb1dd0b961191cd0323516e216502fe7209b03711fc621642245 SHA512 ddbf2b2c4086962e1e51767ebf0ab61f6199a2aad8d85be40c3fb731247a93744365757803cc6e3f190dc130282cbf7f01a6f9f8acac277011e7d767a24b2ba3 WHIRLPOOL d050dfa80a6f6be845a5a201164b508020c2ca492cad520f92fe470205d3bdd6f1721c16c0ed02614da28f9c7c0bb56c6567dc95c65e45352a9738bb14d2aa86
DIST xdebug-2.3.1.tgz 266218 SHA256 b50365896089c76d6d64924b66428cc5ef6b4802371e3d422581b3c34d3ca64c SHA512 aca3ce1546f8b99482f55c0f09e532addecff7db4cc81818260b2d3524fd6888e05c15ed0f98f25a139c40e011540705f02aab56f4c52d90212a843459493bd2 WHIRLPOOL 69e4545c1489f240a23ba4ee70afec754471e5cbffdd48a1d5f5db1eace13982807b1e30ae2efd541f79b658613e770ad2dea1ca016a67037e5b5b59ce08fb9c
+DIST xdebug-2.3.3.tgz 268381 SHA256 b27bd09b23136d242dbc94f4503c98f012a521d5597002c9d463a63c6b0cdfe3 SHA512 212604e87caa67b3734befa0f57580532b0edd346ed871bbaba72ba8319ba60eb8d66649cb5716df250f28ef1cd2384ccc6f651b90ab4936dbcb45ef6c5f7438 WHIRLPOOL f228a2527dc9f2a166bdd4f2920537d5bc66e00f528f21ca05b7038ca535fb3011f3f39a39871c5ac0a62d46d3c3f3eb4a76d33e9c33c79b633be252e89af23e
+DIST xdebug-2.4.0beta1.tgz 262845 SHA256 169ac5dc5fe8a06d75467c83a495940472b8d139b2d2204d8859127e6494f0d9 SHA512 9eb662b86e0c7f76200c194e6185ad24f6ae444bde6539a17bf8d0c75e84464bd01e09b97c07faf60de0fb993bb8b18efade388efb1a381ce486994fb1eb270d WHIRLPOOL a97437e8195a54aeadecb25bebfee76d350940d6fd71fa540f44330cc8d1b614e96ac0ab8b3f9bea3fb98c22e55f1dbe8fcc0799be19b28526a30cdb1515d13f
diff --git a/dev-php/xdebug/xdebug-2.3.3.ebuild b/dev-php/xdebug/xdebug-2.3.3.ebuild
new file mode 100644
index 000000000000..7ae3a31ead9e
--- /dev/null
+++ b/dev-php/xdebug/xdebug-2.3.3.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PHP_EXT_NAME="xdebug"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="yes"
+
+USE_PHP="php5-6 php5-5 php5-4"
+
+MY_PV="${PV/_/}"
+MY_PV="${MY_PV/rc/RC}"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+inherit php-ext-source-r2
+
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+
+DESCRIPTION="A PHP debugging and profiling extension"
+HOMEPAGE="http://www.xdebug.org/"
+SRC_URI="http://pecl.php.net/get/${PN}-${MY_PV}.tgz"
+LICENSE="Xdebug"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ ~dev-php/xdebug-client-${PV}"
+
+src_install() {
+ dodoc NEWS README CREDITS
+ php-ext-source-r2_src_install
+
+ php-ext-source-r2_addtoinifiles "xdebug.auto_trace" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.trace_output_dir" '"/tmp"'
+ php-ext-source-r2_addtoinifiles "xdebug.trace_output_name" '"trace.%c"'
+ php-ext-source-r2_addtoinifiles "xdebug.trace_format" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.trace_options" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.collect_includes" '"1"'
+ php-ext-source-r2_addtoinifiles "xdebug.collect_params" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.collect_return" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.collect_vars" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.default_enable" '"1"'
+ php-ext-source-r2_addtoinifiles "xdebug.extended_info" '"1"'
+ php-ext-source-r2_addtoinifiles "xdebug.manual_url" '"http://www.php.net"'
+ php-ext-source-r2_addtoinifiles "xdebug.max_nesting_level" '"100"'
+ php-ext-source-r2_addtoinifiles "xdebug.show_exception_trace" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.show_local_vars" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.show_mem_delta" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump.COOKIE" '"NULL"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump.ENV" '"NULL"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump.FILES" '"NULL"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump.GET" '"NULL"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump.POST" '"NULL"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump.REQUEST" '"NULL"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump.SERVER" '"NULL"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump.SESSION" '"NULL"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump_globals" '"1"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump_once" '"1"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump_undefined" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.profiler_enable" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.profiler_output_dir" '"/tmp"'
+ php-ext-source-r2_addtoinifiles "xdebug.profiler_output_name" '"cachegrind.out.%p"'
+ php-ext-source-r2_addtoinifiles "xdebug.profiler_enable_trigger" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.profiler_append" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.profiler_aggregate" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.remote_enable" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.remote_handler" '"dbgp"'
+ php-ext-source-r2_addtoinifiles "xdebug.remote_host" '"localhost"'
+ php-ext-source-r2_addtoinifiles "xdebug.remote_mode" '"req"'
+ php-ext-source-r2_addtoinifiles "xdebug.remote_port" '"9000"'
+ php-ext-source-r2_addtoinifiles "xdebug.remote_autostart" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.remote_log" '""'
+ php-ext-source-r2_addtoinifiles "xdebug.idekey" '""'
+ php-ext-source-r2_addtoinifiles "xdebug.var_display_max_data" '"512"'
+ php-ext-source-r2_addtoinifiles "xdebug.var_display_max_depth" '"2"'
+ php-ext-source-r2_addtoinifiles "xdebug.var_display_max_children" '"128"'
+
+}
+
+pkg_postinst() {
+ ewarn "We have set xdebug.default_enable to 0 (off), as xdebug can be"
+ ewarn "installed as a dependency, and not all users will want xdebug to be"
+ ewarn "enabled by default. If you want to enable it, you should edit the"
+ ewarn "ini file and set xdebug.default_enable to 1. Alternatively you can"
+ ewarn "call xdebug_enable() in your code."
+}
diff --git a/dev-php/xdebug/xdebug-2.4.0_beta1.ebuild b/dev-php/xdebug/xdebug-2.4.0_beta1.ebuild
new file mode 100644
index 000000000000..29e468df6aba
--- /dev/null
+++ b/dev-php/xdebug/xdebug-2.4.0_beta1.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PHP_EXT_NAME="xdebug"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="yes"
+
+USE_PHP="php7-0 php5-6 php5-5 php5-4"
+
+MY_PV="${PV/_/}"
+MY_PV="${MY_PV/rc/RC}"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+inherit php-ext-source-r2
+
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+
+DESCRIPTION="A PHP debugging and profiling extension"
+HOMEPAGE="http://www.xdebug.org/"
+SRC_URI="http://pecl.php.net/get/${PN}-${MY_PV}.tgz"
+LICENSE="Xdebug"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ ~dev-php/xdebug-client-${PV}"
+
+src_install() {
+ dodoc README.rst CREDITS
+ php-ext-source-r2_src_install
+
+ php-ext-source-r2_addtoinifiles "xdebug.auto_trace" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.trace_output_dir" '"/tmp"'
+ php-ext-source-r2_addtoinifiles "xdebug.trace_output_name" '"trace.%c"'
+ php-ext-source-r2_addtoinifiles "xdebug.trace_format" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.trace_options" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.collect_includes" '"1"'
+ php-ext-source-r2_addtoinifiles "xdebug.collect_params" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.collect_return" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.collect_vars" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.default_enable" '"1"'
+ php-ext-source-r2_addtoinifiles "xdebug.extended_info" '"1"'
+ php-ext-source-r2_addtoinifiles "xdebug.manual_url" '"http://www.php.net"'
+ php-ext-source-r2_addtoinifiles "xdebug.max_nesting_level" '"100"'
+ php-ext-source-r2_addtoinifiles "xdebug.show_exception_trace" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.show_local_vars" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.show_mem_delta" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump.COOKIE" '"NULL"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump.ENV" '"NULL"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump.FILES" '"NULL"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump.GET" '"NULL"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump.POST" '"NULL"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump.REQUEST" '"NULL"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump.SERVER" '"NULL"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump.SESSION" '"NULL"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump_globals" '"1"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump_once" '"1"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump_undefined" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.profiler_enable" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.profiler_output_dir" '"/tmp"'
+ php-ext-source-r2_addtoinifiles "xdebug.profiler_output_name" '"cachegrind.out.%p"'
+ php-ext-source-r2_addtoinifiles "xdebug.profiler_enable_trigger" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.profiler_append" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.profiler_aggregate" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.remote_enable" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.remote_handler" '"dbgp"'
+ php-ext-source-r2_addtoinifiles "xdebug.remote_host" '"localhost"'
+ php-ext-source-r2_addtoinifiles "xdebug.remote_mode" '"req"'
+ php-ext-source-r2_addtoinifiles "xdebug.remote_port" '"9000"'
+ php-ext-source-r2_addtoinifiles "xdebug.remote_autostart" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.remote_log" '""'
+ php-ext-source-r2_addtoinifiles "xdebug.idekey" '""'
+ php-ext-source-r2_addtoinifiles "xdebug.var_display_max_data" '"512"'
+ php-ext-source-r2_addtoinifiles "xdebug.var_display_max_depth" '"2"'
+ php-ext-source-r2_addtoinifiles "xdebug.var_display_max_children" '"128"'
+
+}
+
+pkg_postinst() {
+ ewarn "We have set xdebug.default_enable to 0 (off), as xdebug can be"
+ ewarn "installed as a dependency, and not all users will want xdebug to be"
+ ewarn "enabled by default. If you want to enable it, you should edit the"
+ ewarn "ini file and set xdebug.default_enable to 1. Alternatively you can"
+ ewarn "call xdebug_enable() in your code."
+}