summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-06-15 01:24:05 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-06-15 01:30:28 +0200
commitcd01243b8d494ca06ee9c943b303fc7835d7c5cd (patch)
treec2ff838677007e586ac13570831d6d7c9e54defe /dev-php
parentdev-php/phpunit: bump to v8.5.5 (diff)
downloadgentoo-cd01243b8d494ca06ee9c943b303fc7835d7c5cd.tar.gz
gentoo-cd01243b8d494ca06ee9c943b303fc7835d7c5cd.tar.bz2
gentoo-cd01243b8d494ca06ee9c943b303fc7835d7c5cd.zip
dev-php/PEAR-Log: bump to v1.13.2
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/PEAR-Log/Manifest1
-rw-r--r--dev-php/PEAR-Log/PEAR-Log-1.13.2.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-php/PEAR-Log/Manifest b/dev-php/PEAR-Log/Manifest
index e91471ce704f..0283dfac6270 100644
--- a/dev-php/PEAR-Log/Manifest
+++ b/dev-php/PEAR-Log/Manifest
@@ -1 +1,2 @@
DIST Log-1.13.1.tgz 46764 BLAKE2B dc0f4605ed801818ddf070ec3beb6818af1630d99bec721cd3f487e709f87bd4a1628a05854c48fe9775aab546bdce4618061ef37674aa9921f536deccc6a080 SHA512 246510b7dbff4dc9f9cdd951d76baf2dd377e30ffde6d38cadac10091dcb92f8095406edb6d8a87ebe2330d514ce99f355f84ebfe57cd8a3f3babc316995148a
+DIST Log-1.13.2.tgz 46801 BLAKE2B 529677ed8a840742840a8ebeb5f5c7d4e8a8af257f9c3b1cb9ff990e42e760e0040f7df8d94794f40ec5654cf33e1909b7b48ca3f656d2a2bc0310c6705d6c24 SHA512 a4adaf7ee2af600a6c14ed398159c61a7df73b2c6be928f0ea6bbaf90d4b0e866e5a169953fa7819e293cd5cb29c6aca762ced79f3619dfbb38af1ea8731b1c4
diff --git a/dev-php/PEAR-Log/PEAR-Log-1.13.2.ebuild b/dev-php/PEAR-Log/PEAR-Log-1.13.2.ebuild
new file mode 100644
index 000000000000..384c2311aa5c
--- /dev/null
+++ b/dev-php/PEAR-Log/PEAR-Log-1.13.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="The Log framework provides an abstracted logging system"
+HOMEPAGE="https://pear.php.net/package/Log"
+SRC_URI="http://download.pear.php.net/package/${MY_P}.tgz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+# The DB, Mail, and MDB2 dependencies are technically optional, but
+# automagic. To avoid surprises, we require them unconditionally.
+RDEPEND="dev-lang/php:*
+ dev-php/PEAR-PEAR
+ dev-php/PEAR-DB
+ dev-php/PEAR-Mail
+ dev-php/PEAR-MDB2"
+DEPEND="test? ( ${RDEPEND} )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ dodoc docs/guide.txt misc/log.sql
+ use examples && dodoc -r examples
+
+ # I don't like installing "Log.php" right at the top-level, but any
+ # packages depending on us will expect to find it there and not as
+ # e.g. Log/Log.php.
+ insinto "/usr/share/php/"
+ doins Log.php
+ doins -r Log
+}
+
+src_test() {
+ # Requires the "pear" executable from dev-php/PEAR-PEAR.
+ pear run-tests tests || die
+
+ # The command succeeds regardless of whether or not the test suite
+ # passed, but this file is only written when there was a failure.
+ [[ -f run-tests.log ]] && die "test suite failed"
+}