summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-12-30 21:56:02 -0500
committerMichael Orlitzky <mjo@gentoo.org>2017-12-30 21:56:19 -0500
commitf94e0d0ec17cc141494ad9c5983638b804241250 (patch)
treea75ca29074657924b6ad54a349f3189955415e49 /dev-php
parentapp-text/coolreader: clean -r2 (diff)
downloadgentoo-f94e0d0ec17cc141494ad9c5983638b804241250.tar.gz
gentoo-f94e0d0ec17cc141494ad9c5983638b804241250.tar.bz2
gentoo-f94e0d0ec17cc141494ad9c5983638b804241250.zip
dev-php/pecl-apcu: new revision with php-7.2 support.
The existing stable version 5.1.8 of pecl-apcu works with php-7.2, but the ebuild is missing explicit support for it. This commit adds a new -r1 with that support. Thanks to Conrad Kostecki for the report and the patch. Closes: https://bugs.gentoo.org/641402 Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-apcu/pecl-apcu-5.1.8-r1.ebuild80
1 files changed, 80 insertions, 0 deletions
diff --git a/dev-php/pecl-apcu/pecl-apcu-5.1.8-r1.ebuild b/dev-php/pecl-apcu/pecl-apcu-5.1.8-r1.ebuild
new file mode 100644
index 00000000000..bcf56069751
--- /dev/null
+++ b/dev-php/pecl-apcu/pecl-apcu-5.1.8-r1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PHP_EXT_NAME="apcu"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS=( NOTICE README.md TECHNOTES.txt TODO )
+
+# Define 5.6 here so we get the USE and REQUIRED_USE from the eclass
+# This allows us to depend on the other slot
+USE_PHP="php5-6 php7-0 php7-1 php7-2"
+
+inherit php-ext-pecl-r3
+
+# However, we only really build for 7.x; so redefine it here
+USE_PHP="php7-0 php7-1 php7-2"
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Stripped down version of APC supporting only user cache"
+LICENSE="PHP-3.01"
+SLOT="7"
+IUSE="+mmap"
+
+DEPEND=""
+RDEPEND="${DEPEND} php_targets_php5-6? ( dev-php/pecl-apcu:0[php_targets_php5-6] )"
+
+LOCKS="pthreadmutex pthreadrw spinlock semaphore"
+
+LUSE=""
+for l in ${LOCKS}; do
+ LUSE+="lock_${l} "
+done
+
+IUSE+=" ${LUSE/lock_pthreadrw/+lock_pthreadrw}"
+
+REQUIRED_USE="^^ ( $LUSE )"
+
+src_prepare() {
+ if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 ; then
+ php-ext-source-r3_src_prepare
+ else
+ eapply_user
+ fi
+}
+
+src_configure() {
+ if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 ; then
+ local PHP_EXT_ECONF_ARGS=(
+ --enable-apcu
+ $(use_enable mmap apcu-mmap)
+ $(use_enable lock_pthreadrw apcu-rwlocks)
+ $(use_enable lock_spinlock apcu-spinlocks)
+ )
+
+ php-ext-source-r3_src_configure
+ fi
+}
+
+src_install() {
+ if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 ; then
+ php-ext-pecl-r3_src_install
+
+ insinto /usr/share/php7/apcu
+ doins apc.php
+ fi
+}
+
+pkg_postinst() {
+ if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 ; then
+ elog "The apc.php file shipped with this release of pecl-apcu was"
+ elog "installed into ${EPREFIX}/usr/share/php7/apcu/."
+ elog
+ elog "If you depend on the apc_* functions,"
+ elog "please install dev-php/pecl-apcu_bc as this extension no longer"
+ elog "provides backwards compatibility."
+ fi
+}