summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2016-05-22 12:29:48 -0500
committerAlex Brandt <alunduil@gentoo.org>2016-05-22 12:29:48 -0500
commitc041fa6ef244cde54bb87f1ca821b9c3a17d3ab6 (patch)
tree9598a620311b8376dc2d7d61462e099026ed39cd /dev-python/aiohttp
parentdev-python/multidict: add version 1.1.0_alpha6 (diff)
downloadgentoo-c041fa6ef244cde54bb87f1ca821b9c3a17d3ab6.tar.gz
gentoo-c041fa6ef244cde54bb87f1ca821b9c3a17d3ab6.tar.bz2
gentoo-c041fa6ef244cde54bb87f1ca821b9c3a17d3ab6.zip
dev-python/aiohttp: add version 0.21.6
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-python/aiohttp')
-rw-r--r--dev-python/aiohttp/Manifest1
-rw-r--r--dev-python/aiohttp/aiohttp-0.21.6.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/aiohttp/Manifest b/dev-python/aiohttp/Manifest
index e66633cb4565..f61d495d6108 100644
--- a/dev-python/aiohttp/Manifest
+++ b/dev-python/aiohttp/Manifest
@@ -2,3 +2,4 @@ DIST aiohttp-0.19.0.tar.gz 2173954 SHA256 9bfb173baec179431a1c8f3566185e8ebbd151
DIST aiohttp-0.20.2.tar.gz 513968 SHA256 8801d36d760514ba8404d2c0309a7ecc3a838b85dad3e63e863b44a3116cf02b SHA512 378b867ed531a1f30079b9a42d4000b82efe997b1e1bee3f1c76973712eabf973da74b37b969d43929f18a8b99ac004a22c4b7849bed1f00fe2f88c0bfbcdddb WHIRLPOOL 8853c2c5f8efde97caff2ba99ef44e505dc82a206ecc51028c7db1b95c4232d436acb9109794ca259e4423d83238569f8df7bdfe81f3131321cebbde00f1d068
DIST aiohttp-0.21.4.tar.gz 528945 SHA256 4a5fcb765bf6d2cbc7d42afedf3d22b9cd0a4d643a870b464ca5b071225976d8 SHA512 e9abc66e1f6ba81b94ef5a528e3bca58434f6d30242967a6b69e66ea164a31d076dbd2159b464c6a59c219483e81febfba986066863f6a3811ff0dc8a51adb64 WHIRLPOOL d9f26b397b63d18e32cc754c75078e97cb6b4d3e2400ade75d91f86890e82407302bc2d55e2a30fe8d2bee7dd99fef16e528cf2c9668998662049543a671da66
DIST aiohttp-0.21.5.tar.gz 529005 SHA256 bac5c883721e0818e405597d2778f08a38cc097df01f574462de2cc4f8090559 SHA512 4958d7c58988a95fc5b1e94e4eb7247f59b55e5ba439391c7b072a7ec267491159e1c8c7c6f05e6f7f72e4de5c12784c8d437665c01e6d9fb1e87a3334c1d35c WHIRLPOOL 135368db11316c8f99f39bbf317f791e433a779f61e45070166bab12b4e97165d2c6e732e8da96a848b431c1f26de45e416009bca4e75456025187ea7a41e04e
+DIST aiohttp-0.21.6.tar.gz 528327 SHA256 8709c6d4b7735705ef46e0d5416083f1e92d9a9ab18e2b4c7f7944e831b73428 SHA512 622218ffbc163aefc04730bc9ca36f922182699407ea8fb6e8e5ce01b63e4bbee821e466f1701ecabf2f4c47bf840a572e7f3bcdf0903e8a87b23d5c3e07209b WHIRLPOOL 2d2539635f76903788f063669420de095951f9f509543fe8dfe86d950055bf72bf5728de029d378b71f4bd7ea0955d13bbd84a31b678995cafa5aee1bc1ef05b
diff --git a/dev-python/aiohttp/aiohttp-0.21.6.ebuild b/dev-python/aiohttp/aiohttp-0.21.6.ebuild
new file mode 100644
index 000000000000..7e102cdde444
--- /dev/null
+++ b/dev-python/aiohttp/aiohttp-0.21.6.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="http client/server for asyncio"
+HOMEPAGE="https://pypi.python.org/pypi/aiohttp"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+EGIT_REPO_URI="https://github.com/KeepSafe/aiohttp"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc examples test"
+
+CDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/multidict[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/alabaster-0.6.2[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-newsfeed[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-spelling[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${CDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-raisesregexp[${PYTHON_USEDEP}]
+ www-servers/gunicorn[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ PYTHONPATH="$(PWD):${PYTHONPATH}" ${PYTHON} -m pytest tests/ || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+
+ distutils-r1_python_install_all
+}