summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-13 13:49:21 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-13 14:20:45 +0100
commit72ec75696c791188f27f9653a8f6ffdd436fe60e (patch)
tree2dc49e44b2976c56efccbe9de27ffae289cf40c9 /dev-python/asset/asset-0.6.4.ebuild
parentdev-python/aadict: New package, ebuild written by me (diff)
downloadgentoo-72ec75696c791188f27f9653a8f6ffdd436fe60e.tar.gz
gentoo-72ec75696c791188f27f9653a8f6ffdd436fe60e.tar.bz2
gentoo-72ec75696c791188f27f9653a8f6ffdd436fe60e.zip
dev-python/asset: Version Bump
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/asset/asset-0.6.4.ebuild')
-rw-r--r--dev-python/asset/asset-0.6.4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/asset/asset-0.6.4.ebuild b/dev-python/asset/asset-0.6.4.ebuild
new file mode 100644
index 000000000000..ebc0aa4839b7
--- /dev/null
+++ b/dev-python/asset/asset-0.6.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A package resource and symbol loading helper library"
+HOMEPAGE="https://pypi.python.org/pypi/asset https://github.com/metagriffin/asset"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/aadict-0.2.2[${PYTHON_USEDEP}]
+ >=dev-python/globre-0.0.5[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4.1[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/nose-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/pxml-0.2.11[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ nosetests --verbose || die
+}