summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-03-19 02:01:34 -0400
committerTim Harder <radhermit@gentoo.org>2018-03-19 02:02:24 -0400
commit7391fb192eb81de2150005b688bfd88565b79379 (patch)
tree327960472abe59c210987367caf487fb6cb3a70d /dev-python/bleach
parentdev-python/CommonMark: version bump to 0.7.5 (diff)
downloadgentoo-7391fb192eb81de2150005b688bfd88565b79379.tar.gz
gentoo-7391fb192eb81de2150005b688bfd88565b79379.tar.bz2
gentoo-7391fb192eb81de2150005b688bfd88565b79379.zip
dev-python/bleach: version bump to 2.1.3
Diffstat (limited to 'dev-python/bleach')
-rw-r--r--dev-python/bleach/Manifest1
-rw-r--r--dev-python/bleach/bleach-2.1.3.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/bleach/Manifest b/dev-python/bleach/Manifest
index 39d438afaf77..c8b2e1df7872 100644
--- a/dev-python/bleach/Manifest
+++ b/dev-python/bleach/Manifest
@@ -1,2 +1,3 @@
DIST bleach-1.5.0.tar.gz 36502 BLAKE2B a56eb875a5becd21f7ff71a29db8178a7536a7aadfe81fe178360ba61ba599df9d4d9a782bbf72eb186b61a0b2e3f99058c483cc0d194e735a787319697c7327 SHA512 572a089691af61f096716d96517a96755fe674cc471bdbcff80615ae903eaeff72c47b918ee28a1db60ee5c0253c0c52ba02544f8535ae4f283a3a87a3061124
DIST bleach-2.1.1.tar.gz 58491 BLAKE2B bd1efbfa30cee61b5d8bfd029ff107ddc997d38139bf5b25a70a6731193f6d02a81e1e49c9ffe3eef6cbda864464108cb1f65599c68c48f1033ced27fdb65c29 SHA512 dc8ef7b678966bfebddb2d27c78abf50e71f2d90c5807cf788a08b852a085a4d990368da5dfb5f61a49e0f2f1e7d9ac73c2b6967fdacb55663ae2c339016d4c2
+DIST bleach-2.1.3.tar.gz 60141 BLAKE2B 5c04269266007e31e1a01540198177afb6b13362b89815073b7cd68668da26725f2631defdb26d124ae6c74743de0d31b2975a0d19f58e032ac2332e3ea46a75 SHA512 ff74fb3646709f20c79ea02e6d0fb93e2f204d3151a05f259b703050c10d410859af76acb470405f6fb7b55c8fb64595e6f0fcf8e9cb8fd3fc3722fa30a47de5
diff --git a/dev-python/bleach/bleach-2.1.3.ebuild b/dev-python/bleach/bleach-2.1.3.ebuild
new file mode 100644
index 000000000000..7d6101cf43a6
--- /dev/null
+++ b/dev-python/bleach/bleach-2.1.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="an easy whitelist-based HTML-sanitizing tool"
+HOMEPAGE="https://github.com/mozilla/bleach https://pypi.python.org/pypi/bleach"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/html5lib-0.99999999[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( >=dev-python/pytest-3.0.3[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ py.test -v || die "tests failed under ${EPYTHON}"
+}