summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-02-27 11:02:46 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-02-27 11:49:07 +0100
commiteb77bc986bf7230ee17b508e335c5294988b4411 (patch)
tree5ab048017f324454200c812f65aa0e5c51f424d4 /dev-python/catkin_pkg/catkin_pkg-0.2.10.ebuild
parentsys-apps/less: Removed old. (diff)
downloadgentoo-eb77bc986bf7230ee17b508e335c5294988b4411.tar.gz
gentoo-eb77bc986bf7230ee17b508e335c5294988b4411.tar.bz2
gentoo-eb77bc986bf7230ee17b508e335c5294988b4411.zip
dev-python/catkin_pkg: remove old
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/catkin_pkg/catkin_pkg-0.2.10.ebuild')
-rw-r--r--dev-python/catkin_pkg/catkin_pkg-0.2.10.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/dev-python/catkin_pkg/catkin_pkg-0.2.10.ebuild b/dev-python/catkin_pkg/catkin_pkg-0.2.10.ebuild
deleted file mode 100644
index fbc5d3f2d01c..000000000000
--- a/dev-python/catkin_pkg/catkin_pkg-0.2.10.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy{,3} )
-
-SCM=""
-if [ "${PV#9999}" != "${PV}" ] ; then
- SCM="git-r3"
- EGIT_REPO_URI="https://github.com/ros-infrastructure/catkin_pkg"
-fi
-
-inherit ${SCM} distutils-r1
-
-DESCRIPTION="Standalone Python library for the catkin package system"
-HOMEPAGE="http://wiki.ros.org/catkin_pkg"
-if [ "${PV#9999}" != "${PV}" ] ; then
- SRC_URI=""
- KEYWORDS=""
-else
- SRC_URI="
- http://download.ros.org/downloads/${PN}/${P}.tar.gz
- https://github.com/ros-infrastructure/catkin_pkg/archive/${PV}.tar.gz -> ${P}.tar.gz
- "
- KEYWORDS="~amd64 ~arm"
-fi
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="test"
-
-RDEPEND="
- dev-python/docutils[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- test? ( dev-python/mock[${PYTHON_USEDEP}] dev-python/nose[${PYTHON_USEDEP}] )
-"
-PATCHES=( "${FILESDIR}/catkin_prefix.patch" )
-
-python_test() {
- nosetests -s --tests test || die
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- # Avoid recursing in the whole hierarchy
- dodir /usr/
- touch "${ED}/usr/CATKIN_IGNORE"
-}