summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/configobj
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/configobj')
-rw-r--r--dev-python/configobj/Manifest3
-rw-r--r--dev-python/configobj/configobj-4.7.2-r2.ebuild41
-rw-r--r--dev-python/configobj/configobj-5.0.5.ebuild30
-rw-r--r--dev-python/configobj/configobj-5.0.6.ebuild30
-rw-r--r--dev-python/configobj/files/configobj-4.7.2-fix_tests.patch11
-rw-r--r--dev-python/configobj/metadata.xml14
6 files changed, 129 insertions, 0 deletions
diff --git a/dev-python/configobj/Manifest b/dev-python/configobj/Manifest
new file mode 100644
index 000000000000..8ebb884657fd
--- /dev/null
+++ b/dev-python/configobj/Manifest
@@ -0,0 +1,3 @@
+DIST configobj-4.7.2.zip 143618 SHA256 332a0d20d4d736d521d95cb2cf069b1ac7c858985207db4296f4050396558c49 SHA512 510b7ce461932d504808a9aeb539265b9fddb17c9451076f8b6be796f38617a5095d3c287c78c38a1825d76be462ca0224f5ae3b614f67fd69c6260b399d802f WHIRLPOOL e38ea000479792be4c9ddf17fca8d17bc486cd2ef0363a7fc29922012b485ca8c2a9ac8b7eb06676783b87ca8ec37da41a8a44e7111dcaf07244318e1599924b
+DIST configobj-5.0.5.tar.gz 33232 SHA256 766eff273f2cbb007a3ea8aa69429ee9b1553aa96fe282c6ace3769b9ac47b08 SHA512 6dfb30fff22b1a62a191876161c20c7236d49137a0def85ea2ddf80a6810347f586bbec2dffbcd58ed942591f362b7741ec2f9464fb377e852edc6748b12ba6a WHIRLPOOL ff4c202b15188f501f2538db16a518e154a93bffa31c2d89e509220967d6bde51f7dc1e062f3d57895bf024a04554f42cc8d527d89b93ff9a6e1127dadc9d035
+DIST configobj-5.0.6.tar.gz 33248 SHA256 a2f5650770e1c87fb335af19a9b7eb73fc05ccf22144eb68db7d00cd2bcb0902 SHA512 f253fdd0bc3fcd37f56c9ceb28f5c8c739b0861e099b07a3929645907c97b2261f0529850a95c1a42507846f72d88a0992fcd1e1d6fa8654dc713d120f769963 WHIRLPOOL fc8472d7fd161f4ccd09e3d99c6e97d3ecfe008b3cd16d623ef6ecd598148a41b4658c6ce7488f30eb581e2fcc09bbb8887240e77582d3c272b88c8da87ebb08
diff --git a/dev-python/configobj/configobj-4.7.2-r2.ebuild b/dev-python/configobj/configobj-4.7.2-r2.ebuild
new file mode 100644
index 000000000000..c3fcd7027a81
--- /dev/null
+++ b/dev-python/configobj/configobj-4.7.2-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Simple config file reader and writer"
+HOMEPAGE="http://www.voidspace.org.uk/python/configobj.html http://code.google.com/p/configobj/ http://pypi.python.org/pypi/configobj"
+SRC_URI="mirror://sourceforge/${PN}/${P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="doc"
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+PATCHES=( "${FILESDIR}"/${P}-fix_tests.patch )
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ sed -e "s/ \(doctest\.testmod(.*\)/ sys.exit(\1[0] != 0)/" -i validate.py || die
+}
+
+python_test() {
+ "${PYTHON}" validate.py -v || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use doc; then
+ rm -f docs/BSD*
+ insinto /usr/share/doc/${PF}/html
+ doins -r docs/* || die "doins failed"
+ fi
+}
diff --git a/dev-python/configobj/configobj-5.0.5.ebuild b/dev-python/configobj/configobj-5.0.5.ebuild
new file mode 100644
index 000000000000..8d43f8cce3fc
--- /dev/null
+++ b/dev-python/configobj/configobj-5.0.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple config file reader and writer"
+HOMEPAGE="http://www.voidspace.org.uk/python/configobj.html http://code.google.com/p/configobj/ http://pypi.python.org/pypi/configobj"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ # Not to install un-needed _version.py
+ sed -e "/^MODULES =/s/, '_version'//" -i setup.py
+ sed -e "s/^from _version import __version__$/__version__ = '${PV}'/" -i configobj.py
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${PYTHON}" validate.py -v || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/configobj/configobj-5.0.6.ebuild b/dev-python/configobj/configobj-5.0.6.ebuild
new file mode 100644
index 000000000000..396c1a6bb7cc
--- /dev/null
+++ b/dev-python/configobj/configobj-5.0.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple config file reader and writer"
+HOMEPAGE="http://www.voidspace.org.uk/python/configobj.html http://code.google.com/p/configobj/ http://pypi.python.org/pypi/configobj"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ # Not to install un-needed _version.py
+ sed -e "/^MODULES =/s/, '_version'//" -i setup.py
+ sed -e "s/^from _version import __version__$/__version__ = '${PV}'/" -i configobj.py
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${PYTHON}" validate.py -v || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/configobj/files/configobj-4.7.2-fix_tests.patch b/dev-python/configobj/files/configobj-4.7.2-fix_tests.patch
new file mode 100644
index 000000000000..c0b867e0ee7c
--- /dev/null
+++ b/dev-python/configobj/files/configobj-4.7.2-fix_tests.patch
@@ -0,0 +1,11 @@
+--- validate.py
++++ validate.py
+@@ -268,8 +268,6 @@
+ 16908291
+ >>> int(dottedQuadToNum('1.2.3.4'))
+ 16909060
+- >>> dottedQuadToNum('255.255.255.255')
+- 4294967295L
+ >>> dottedQuadToNum('255.255.255.256')
+ Traceback (most recent call last):
+ ValueError: Not a good dotted-quad IP: 255.255.255.256
diff --git a/dev-python/configobj/metadata.xml b/dev-python/configobj/metadata.xml
new file mode 100644
index 000000000000..8deebe785efb
--- /dev/null
+++ b/dev-python/configobj/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription lang="en">
+ ConfigObj is a simple but powerful config file reader and writer: an
+ ini file round tripper. Its main feature is that it is very easy to
+ use, with a straightforward programmer's interface and a simple syntax
+ for config files.
+</longdescription>
+ <upstream>
+ <remote-id type="pypi">configobj</remote-id>
+ </upstream>
+</pkgmetadata>