summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/django-openid-auth
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/django-openid-auth')
-rw-r--r--dev-python/django-openid-auth/Manifest1
-rw-r--r--dev-python/django-openid-auth/django-openid-auth-0.5.ebuild25
-rw-r--r--dev-python/django-openid-auth/metadata.xml13
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/django-openid-auth/Manifest b/dev-python/django-openid-auth/Manifest
new file mode 100644
index 000000000000..e3758b783ae7
--- /dev/null
+++ b/dev-python/django-openid-auth/Manifest
@@ -0,0 +1 @@
+DIST django-openid-auth-0.5.tar.gz 32722 SHA256 2ceb25b16140d6ee02e1c65948c18aa184d62350452a2b4b2f44819b69866dfc SHA512 9d1444aa15d450acc6ffc1ddc8359253828b2cceeee57e98268c1ae25bbcb1e2facd1e065c9e29fa3b167efb86923d72408cc43442b18d6dbed4dca05c33548b WHIRLPOOL 56dc25394756e2dfaed1eca82db60b132ab5c728e08c898b3072f211044fbb6335c51dc11576f60a37f86b41e3fb7a8f8306029b0b559a3260ac57cbd1046d22
diff --git a/dev-python/django-openid-auth/django-openid-auth-0.5.ebuild b/dev-python/django-openid-auth/django-openid-auth-0.5.ebuild
new file mode 100644
index 000000000000..ce5bbe119388
--- /dev/null
+++ b/dev-python/django-openid-auth/django-openid-auth-0.5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A library that can be used to add OpenID support to Django applications"
+HOMEPAGE="https://launchpad.net/django-openid-auth"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${PN}-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/django-1.3[${PYTHON_USEDEP}]
+ >=dev-python/python-openid-2.2.0[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+EXAMPLES=( example_consumer/ )
diff --git a/dev-python/django-openid-auth/metadata.xml b/dev-python/django-openid-auth/metadata.xml
new file mode 100644
index 000000000000..e314c7897b44
--- /dev/null
+++ b/dev-python/django-openid-auth/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>ercpe@gentoo.org</email>
+ <name>Johann Schmitz</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ryanmcgrath/twython</remote-id>
+ <remote-id type="launchpad">django-openid-auth</remote-id>
+ </upstream>
+</pkgmetadata>