summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-09 11:37:27 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-09 11:49:37 +0200
commita7e6cd2c880d2e40d6fbc36018e485f0fe404881 (patch)
treee50ebf8e21a1bc67bec5e84dcb4ee054ddba6ec2 /dev-python/execnet
parentdev-python/pytest-cache: Add pypy* support (diff)
downloadgentoo-a7e6cd2c880d2e40d6fbc36018e485f0fe404881.tar.gz
gentoo-a7e6cd2c880d2e40d6fbc36018e485f0fe404881.tar.bz2
gentoo-a7e6cd2c880d2e40d6fbc36018e485f0fe404881.zip
dev-python/execnet: Version Bump
Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/execnet')
-rw-r--r--dev-python/execnet/Manifest1
-rw-r--r--dev-python/execnet/execnet-1.3.0.ebuild2
-rw-r--r--dev-python/execnet/execnet-1.4.1.ebuild51
3 files changed, 53 insertions, 1 deletions
diff --git a/dev-python/execnet/Manifest b/dev-python/execnet/Manifest
index 82658ac0e0f6..4c3ce4900599 100644
--- a/dev-python/execnet/Manifest
+++ b/dev-python/execnet/Manifest
@@ -1,2 +1,3 @@
DIST execnet-1.2.0.tar.gz 163876 SHA256 951714caa0ae80237f4ffc1f08450e9e2e5f8f902beaf1ad294020875d6f8c2c SHA512 bf4eb1c07832628863f3d315510628343bc4504050311a277a86100a825df8ed5f6b65f58db28ea6733f3886b6007eae7fd33586721374f9ffb3687e9b95d5c4 WHIRLPOOL 898d9427d55e316f2cdfe06d8dadd0f40d8d2374802b419c9b7aac279eed36919f8dc0084c9c253b3b3d75e9dd50ec2748ef2227e803bf900d7d8b0d5395c45e
DIST execnet-1.3.0.tar.gz 170489 SHA256 ecdfd5613cc78fe99aaf3e351bc870d1428202d78744ea48c893bf34a1fcbdbe SHA512 b047639ede7f5eeb600358bf983d1db617438a8ed9dcaa6e0ba470fe15703f2ce8d3f413a6b6dc575c0090744fde82ba3ba0e684bdeda86a6261941125c71a10 WHIRLPOOL 54d6cebfabcabfd5c3baebadd66fe8837c79cead4900ec1b9d55478d2eb2cbd77be9dfbb108b4049836b5cd316316bd4304b11377d372e5d5b8ef23f684e5838
+DIST execnet-1.4.1.tar.gz 171041 SHA256 f66dd4a7519725a1b7e14ad9ae7d3df8e09b2da88062386e08e941cafc0ef3e6 SHA512 e8c0c32e873f8585ff4d4da3b9cbd40046479370f5653f67a98c9029d4535a619731d1b825332fe4af4dc5ebc9ab11ee879ef45df07f08943b1e1685f2255790 WHIRLPOOL 487c31617b78e4eeed9dc75ae8f01ade33aad35f7547677ec007b688071dd56e69c4f4b92cf9355dee7cea97bf6eac09f508099f104cf52d6c9fe3860e4fd3c9
diff --git a/dev-python/execnet/execnet-1.3.0.ebuild b/dev-python/execnet/execnet-1.3.0.ebuild
index 212256b81886..c91ab84a2840 100644
--- a/dev-python/execnet/execnet-1.3.0.ebuild
+++ b/dev-python/execnet/execnet-1.3.0.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
inherit distutils-r1
diff --git a/dev-python/execnet/execnet-1.4.1.ebuild b/dev-python/execnet/execnet-1.4.1.ebuild
new file mode 100644
index 000000000000..7e5cad3119e4
--- /dev/null
+++ b/dev-python/execnet/execnet-1.4.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Rapid multi-Python deployment"
+HOMEPAGE="http://codespeak.net/execnet/ https://pypi.python.org/pypi/execnet/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=">=dev-python/apipkg-1.4[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+#PATCHES=( "${FILESDIR}"/1.2.0-tests.patch )
+
+python_prepare_all() {
+ # Remove doctest that access an i'net site
+ rm doc/example/test_info.txt || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ # https://bitbucket.org/hpk42/execnet/issue/10
+ unset PYTHONDONTWRITEBYTECODE
+ py.test testing || die "Tests fail with ${EPYTHON}"
+
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+
+ distutils-r1_python_install_all
+}