summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/flask-peewee
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/flask-peewee')
-rw-r--r--dev-python/flask-peewee/Manifest2
-rw-r--r--dev-python/flask-peewee/flask-peewee-0.6.5.ebuild32
-rw-r--r--dev-python/flask-peewee/flask-peewee-0.6.6.ebuild48
-rw-r--r--dev-python/flask-peewee/metadata.xml8
4 files changed, 90 insertions, 0 deletions
diff --git a/dev-python/flask-peewee/Manifest b/dev-python/flask-peewee/Manifest
new file mode 100644
index 000000000000..1300a8063ea0
--- /dev/null
+++ b/dev-python/flask-peewee/Manifest
@@ -0,0 +1,2 @@
+DIST flask-peewee-0.6.5.tar.gz 702466 SHA256 7b39fac44b86e057a44fc059193e444cefbf3aa7807ba3022fa090ac50ce89c2 SHA512 4e1f01d78d1c778cd95a784920d8cfbddc712b8224d93cd0dfe566ee007b781dc4b353bb27c4240475234660363b2b77093d504bf5ef90f358e116f8373020d5 WHIRLPOOL 14e89a5cdf83dbebe377eead7fefcbc56463c889f753fb56198808f0c739c67a68e39c8ff3ad0a304d0843f99147a9771bf0769a731ad28e2d07d28ae084824f
+DIST flask-peewee-0.6.6.tar.gz 707197 SHA256 eab798e102d0e5d7ddba995ac7a82e34e7da815839fa16ee62aa6e4f4a2ee161 SHA512 046a7f89920986cf6847a6cceeb2ed7994317b5957530f6bee3d371445a7db9cb2500943b29da9a6ccfe5c3372e06a392e140480989eb65811b3b92d6bed9c52 WHIRLPOOL dd28bb5c21eb57b6167a5a24594aa7dd74620c28a01321a59f6f15f9773b5c69cf6bc4a2b49ba0e8e72af6b238546419404c13df8aed146f4ee8695cda5f7636
diff --git a/dev-python/flask-peewee/flask-peewee-0.6.5.ebuild b/dev-python/flask-peewee/flask-peewee-0.6.5.ebuild
new file mode 100644
index 000000000000..cc1ebb87bd8e
--- /dev/null
+++ b/dev-python/flask-peewee/flask-peewee-0.6.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+RESTRICT="test" # broken
+
+DESCRIPTION="Flask integration layer for the Peewee ORM"
+HOMEPAGE="https://pypi.python.org/pypi/Flask-Admin"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+RDEPEND="dev-python/flask[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/peewee[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+ "
+
+python_test() {
+ nosetests || die "Testing failed with ${EPYTHON}"
+}
diff --git a/dev-python/flask-peewee/flask-peewee-0.6.6.ebuild b/dev-python/flask-peewee/flask-peewee-0.6.6.ebuild
new file mode 100644
index 000000000000..09b0fc765fe4
--- /dev/null
+++ b/dev-python/flask-peewee/flask-peewee-0.6.6.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+RESTRICT="test" # broken
+
+DESCRIPTION="Flask integration layer for the Peewee ORM"
+HOMEPAGE="https://pypi.python.org/pypi/Flask-Admin"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+RDEPEND="
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/peewee[${PYTHON_USEDEP}]
+ dev-python/wtforms[${PYTHON_USEDEP}]
+ dev-python/wtf-peewee[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ )"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( example/. )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/flask-peewee/metadata.xml b/dev-python/flask-peewee/metadata.xml
new file mode 100644
index 000000000000..5703928ba3ac
--- /dev/null
+++ b/dev-python/flask-peewee/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">flask-peewee</remote-id>
+ </upstream>
+</pkgmetadata>