summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-04-16 23:31:16 +0200
committerIan Delaney <idella4@gentoo.org>2016-04-17 19:39:41 +0800
commitab7082040850d37e266fcbe76a0e79fffe340ac4 (patch)
tree38c64ee85e3bf6ef13bbf023e68b6bc1f3a919c8 /dev-python/flask-sqlalchemy
parentdev-ruby/rest-client: Remove ruby19 (diff)
downloadgentoo-ab7082040850d37e266fcbe76a0e79fffe340ac4.tar.gz
gentoo-ab7082040850d37e266fcbe76a0e79fffe340ac4.tar.bz2
gentoo-ab7082040850d37e266fcbe76a0e79fffe340ac4.zip
dev-python/flask-sqlalchemy: add Python 3.5 support, EAPI=6
Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/1287 Signed-off-by: Ian Delaney <idella4@gentoo.org>
Diffstat (limited to 'dev-python/flask-sqlalchemy')
-rw-r--r--dev-python/flask-sqlalchemy/files/mapping.patch4
-rw-r--r--dev-python/flask-sqlalchemy/flask-sqlalchemy-2.1.ebuild6
-rw-r--r--dev-python/flask-sqlalchemy/metadata.xml6
3 files changed, 11 insertions, 5 deletions
diff --git a/dev-python/flask-sqlalchemy/files/mapping.patch b/dev-python/flask-sqlalchemy/files/mapping.patch
index 32bee9c4f148..af6572489a4f 100644
--- a/dev-python/flask-sqlalchemy/files/mapping.patch
+++ b/dev-python/flask-sqlalchemy/files/mapping.patch
@@ -1,6 +1,6 @@
diff -ur Flask-SQLAlchemy-1.0.orig/docs/conf.py Flask-SQLAlchemy-1.0/docs/conf.py
---- docs/conf.py 2013-01-27 08:57:36.000000000 +0800
-+++ docs/conf.py 2014-04-03 18:08:34.772268079 +0800
+--- a/docs/conf.py 2013-01-27 08:57:36.000000000 +0800
++++ b/docs/conf.py 2014-04-03 18:08:34.772268079 +0800
@@ -224,9 +224,9 @@
diff --git a/dev-python/flask-sqlalchemy/flask-sqlalchemy-2.1.ebuild b/dev-python/flask-sqlalchemy/flask-sqlalchemy-2.1.ebuild
index 0b58296ca5e7..7a4cff5c2c77 100644
--- a/dev-python/flask-sqlalchemy/flask-sqlalchemy-2.1.ebuild
+++ b/dev-python/flask-sqlalchemy/flask-sqlalchemy-2.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} pypy )
inherit distutils-r1
diff --git a/dev-python/flask-sqlalchemy/metadata.xml b/dev-python/flask-sqlalchemy/metadata.xml
index 74a0a807e782..53187fdda862 100644
--- a/dev-python/flask-sqlalchemy/metadata.xml
+++ b/dev-python/flask-sqlalchemy/metadata.xml
@@ -10,5 +10,11 @@
</maintainer>
<upstream>
<remote-id type="pypi">Flask-SQLAlchemy</remote-id>
+ <remote-id type="github">mitsuhiko/flask-sqlalchemy</remote-id>
+ <bugs-to>https://github.com/mitsuhiko/flask-sqlalchemy/issues</bugs-to>
</upstream>
+ <longdescription lang="en">
+ Flask-SQLAlchemy is a Flask microframework extension which adds
+ support for the SQLAlchemy SQL toolkit/ORM.
+ </longdescription>
</pkgmetadata>