summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/jonpy
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/jonpy')
-rw-r--r--dev-python/jonpy/Manifest2
-rw-r--r--dev-python/jonpy/jonpy-0.10-r1.ebuild26
-rw-r--r--dev-python/jonpy/jonpy-0.11.ebuild23
-rw-r--r--dev-python/jonpy/metadata.xml8
4 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/jonpy/Manifest b/dev-python/jonpy/Manifest
new file mode 100644
index 000000000000..142ad248f2b1
--- /dev/null
+++ b/dev-python/jonpy/Manifest
@@ -0,0 +1,2 @@
+DIST jonpy-0.10.tar.gz 51672 SHA256 33f43845b6403a2596d89e2210ba043d73facd39937e04eb59d0b7ef683b9456 SHA512 2dcea6798e186a1bfd767f3a0b331ee5ca56e2c0df63b8ac1f3ac53c9906ca98387a0d47166c11057cee62dc669de0771eba6e72d59d5ecd0e88b2fcd5b70281 WHIRLPOOL 8a9e7334d31f822bab462cee321bb520922f070ca569588881ed741ebf0580967d2222f1caf521941a3db3bd8b801f825e485c11dd481a5c66975e293878666f
+DIST jonpy-0.11.tar.gz 51496 SHA256 983f0af78c6a4cdf843da8449a297681be358476764a06ccdd0cb838a6979a7c SHA512 9fa925259a5d56347b71845fc0ed00f16f4b411b350a08f0779f8f867fc34d0c6164cb0dc107410b6b88d1565fc504cabd102a0c7fcbb86e7163319a235d89ee WHIRLPOOL f3166d7cf06c64cde822baee35c15449eedf31b342a5eea5786eb5ee83645fcc6a93537ec0654e5d851ab9ab5880a17039eaa367708ee13df0d36208bc0cba86
diff --git a/dev-python/jonpy/jonpy-0.10-r1.ebuild b/dev-python/jonpy/jonpy-0.10-r1.ebuild
new file mode 100644
index 000000000000..27ae37d2abdd
--- /dev/null
+++ b/dev-python/jonpy/jonpy-0.10-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Powerful multi-threaded object-oriented CGI/FastCGI/mod_python/html-templating facilities"
+HOMEPAGE="http://jonpy.sourceforge.net/ http://pypi.python.org/pypi/jonpy"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+DEPEND=""
+RDEPEND=""
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/. )
+ use examples && local EXAMPLES=( example/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/jonpy/jonpy-0.11.ebuild b/dev-python/jonpy/jonpy-0.11.ebuild
new file mode 100644
index 000000000000..29a2699ceeff
--- /dev/null
+++ b/dev-python/jonpy/jonpy-0.11.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Powerful multi-threaded object-oriented CGI/FastCGI/mod_python/html-templating facilities"
+HOMEPAGE="http://jonpy.sourceforge.net/ http://pypi.python.org/pypi/jonpy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc examples"
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/. )
+ use examples && local EXAMPLES=( example/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/jonpy/metadata.xml b/dev-python/jonpy/metadata.xml
new file mode 100644
index 000000000000..42e1741985c7
--- /dev/null
+++ b/dev-python/jonpy/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">jonpy</remote-id>
+ </upstream>
+</pkgmetadata>