summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-11-07 14:06:35 +0100
committerManuel Rüger <mrueg@gentoo.org>2017-11-07 14:07:01 +0100
commit8c42556579669c2d8047424b3bb1316fcfed7e5f (patch)
tree0b2becd661b8432d473f1d43e2100951a602c2e7 /dev-python/libnacl/libnacl-1.6.1.ebuild
parentnet-libs/nodejs: Old. (diff)
downloadgentoo-8c42556579669c2d8047424b3bb1316fcfed7e5f.tar.gz
gentoo-8c42556579669c2d8047424b3bb1316fcfed7e5f.tar.bz2
gentoo-8c42556579669c2d8047424b3bb1316fcfed7e5f.zip
dev-python/libnacl: Version bump to 1.6.1
Package-Manager: Portage-2.3.12, Repoman-2.3.4
Diffstat (limited to 'dev-python/libnacl/libnacl-1.6.1.ebuild')
-rw-r--r--dev-python/libnacl/libnacl-1.6.1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/libnacl/libnacl-1.6.1.ebuild b/dev-python/libnacl/libnacl-1.6.1.ebuild
new file mode 100644
index 000000000000..19dc1f1821e4
--- /dev/null
+++ b/dev-python/libnacl/libnacl-1.6.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+inherit distutils-r1
+
+DESCRIPTION="Python ctypes wrapper for libsodium"
+HOMEPAGE="https://libnacl.readthedocs.org/"
+SRC_URI="https://github.com/saltstack/libnacl/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-libs/libsodium"
+
+python_test() {
+ ${EPYTHON} tests/runtests.py || die
+}