summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-01-03 21:17:09 +0100
committerMichał Górny <mgorny@gentoo.org>2018-01-03 23:21:35 +0100
commit04f6022ab6327f315f5f0079a03705f7ef6bd835 (patch)
tree473f64c711150e9027a07c580f543013c8f4354a /dev-python/lit
parentsys-devel/llvm-common: Add a live ebuild for 6.0 branch (diff)
downloadgentoo-04f6022ab6327f315f5f0079a03705f7ef6bd835.tar.gz
gentoo-04f6022ab6327f315f5f0079a03705f7ef6bd835.tar.bz2
gentoo-04f6022ab6327f315f5f0079a03705f7ef6bd835.zip
dev-python/lit: Add a live ebuild for 6.0 branch
Diffstat (limited to 'dev-python/lit')
-rw-r--r--dev-python/lit/lit-6.0.9999.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/lit/lit-6.0.9999.ebuild b/dev-python/lit/lit-6.0.9999.ebuild
new file mode 100644
index 000000000000..f167a14c32b7
--- /dev/null
+++ b/dev-python/lit/lit-6.0.9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+inherit distutils-r1 git-r3
+
+DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
+HOMEPAGE="https://llvm.org/"
+SRC_URI=""
+EGIT_REPO_URI="https://git.llvm.org/git/llvm.git
+ https://github.com/llvm-mirror/llvm.git"
+EGIT_BRANCH="release_60"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+S=${WORKDIR}/${P}/utils/lit
+
+# Tests require 'FileCheck' and 'not' utilities (from llvm)
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ sys-devel/llvm )"
+
+# TODO: move the manpage generation here (from sys-devel/llvm)
+
+src_unpack() {
+ git-r3_fetch
+ git-r3_checkout '' '' '' utils/lit
+}
+
+python_test() {
+ ./lit.py -vv tests || die
+}