summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2017-11-10 10:17:29 +0100
committerDavid Seifert <soap@gentoo.org>2017-11-17 19:43:33 +0100
commit5e1167894d7eb47ec8318367deb21825b71dfff2 (patch)
tree64356ba2ce8242d01dda3ceeb63206a98d19649c /dev-python/matplotlib2tikz
parentdev-python/nbformat: Version bump to 4.4.0 (diff)
downloadgentoo-5e1167894d7eb47ec8318367deb21825b71dfff2.tar.gz
gentoo-5e1167894d7eb47ec8318367deb21825b71dfff2.tar.bz2
gentoo-5e1167894d7eb47ec8318367deb21825b71dfff2.zip
dev-python/matplotlib2tikz: Version bump to 0.6.14
Package-Manager: Portage-2.3.8, Repoman-2.3.3 Closes: https://github.com/gentoo/gentoo/pull/6166
Diffstat (limited to 'dev-python/matplotlib2tikz')
-rw-r--r--dev-python/matplotlib2tikz/Manifest1
-rw-r--r--dev-python/matplotlib2tikz/matplotlib2tikz-0.6.14.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/matplotlib2tikz/Manifest b/dev-python/matplotlib2tikz/Manifest
index e58a82f8833d..d1fff6aa1917 100644
--- a/dev-python/matplotlib2tikz/Manifest
+++ b/dev-python/matplotlib2tikz/Manifest
@@ -1 +1,2 @@
DIST matplotlib2tikz-0.6.13.tar.gz 524735 SHA256 ce6de9226316d4b5ae3ce0d57c7cf445d219e6842bdc041820c0c39ee9af339c SHA512 f42e96ab60005b96f9327e34ff9df444e9a371334c77b0bad85343beeb20a5c4c2df5539fd0200cf306a4cfed6926f191d547bf2ed69a98c4a9f2e1c2ae0da7b WHIRLPOOL f6ff4d4d8837394e1aacc2c66686cc711b64b6d7aad95620e402b4f1494436b8d2248ce8fbb947ec9d4a93442aba1c1cf03eed9423ff19f31b98060678274785
+DIST matplotlib2tikz-0.6.14.tar.gz 525576 SHA256 c0f7e526029f6811d8f4f75851e6a1dbd23090190b1eec68dfaf4ce082bb550d SHA512 d69b5bbb3e5aa298fe38ca0599436e12a8cf7628936fc24a641fff38b4429e1117f2f239fc41338e8459f8be1be55d7607808ad171bc256eff1f76a69079ac1a WHIRLPOOL c395b6110bece4b272945e5d0ad35640595dac93b009bcd0c2a89d2881f95efa5802908996dbbb8a1d436a44574a9a538106f14eb43658f5b86b82b08f3ae44c
diff --git a/dev-python/matplotlib2tikz/matplotlib2tikz-0.6.14.ebuild b/dev-python/matplotlib2tikz/matplotlib2tikz-0.6.14.ebuild
new file mode 100644
index 000000000000..28505b0459e4
--- /dev/null
+++ b/dev-python/matplotlib2tikz/matplotlib2tikz-0.6.14.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Convert matplotlib figures into TikZ/PGFPlots"
+HOMEPAGE="https://github.com/nschloe/matplotlib2tikz"
+SRC_URI="https://github.com/nschloe/matplotlib2tikz/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/ImageHash[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-tex/pgf
+ )"
+
+# we have not succeeded in getting the tests to work yet ;-)
+RESTRICT="test"
+
+python_test() {
+ local -x MPLBACKEND=Agg
+ virtx py.test -v || die "Tests failed with ${EPYTHON}"
+}