summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/minimock
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/minimock')
-rw-r--r--dev-python/minimock/Manifest1
-rw-r--r--dev-python/minimock/metadata.xml8
-rw-r--r--dev-python/minimock/minimock-1.2.8-r1.ebuild25
3 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/minimock/Manifest b/dev-python/minimock/Manifest
new file mode 100644
index 000000000000..f8e476f1dabe
--- /dev/null
+++ b/dev-python/minimock/Manifest
@@ -0,0 +1 @@
+DIST MiniMock-1.2.8.tar.gz 13217 SHA256 5fdfdfeadf0fc781d0592a1b90d2fcc11581f682ff7cba6201cfdb15c3ea5a4c SHA512 91133251a6e6b1acc11e6ac4f24404807134f8a7fca49d5f7365d7fdfc6bdd1527e7382da8d866669408b1ad30331a176026dd31bcb0c3b7367b7f778fc61ca7 WHIRLPOOL 768a73dc82499615ee0d0ce9dd7a3e67253c27908778b0fcd0bf07d562254f48ba95128ced78b7599ccf77cf19bec1c1b85d21a60d251f302825516800bda69e
diff --git a/dev-python/minimock/metadata.xml b/dev-python/minimock/metadata.xml
new file mode 100644
index 000000000000..c88fc0c84b80
--- /dev/null
+++ b/dev-python/minimock/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">MiniMock</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/minimock/minimock-1.2.8-r1.ebuild b/dev-python/minimock/minimock-1.2.8-r1.ebuild
new file mode 100644
index 000000000000..de28ebee220e
--- /dev/null
+++ b/dev-python/minimock/minimock-1.2.8-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+MY_PN="MiniMock"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="The simplest possible mock library"
+HOMEPAGE="http://pypi.python.org/pypi/MiniMock"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm ppc x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( docs/changelog.rst docs/index.rst )