summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/oauth2client
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/oauth2client')
-rw-r--r--dev-python/oauth2client/Manifest2
-rw-r--r--dev-python/oauth2client/metadata.xml8
-rw-r--r--dev-python/oauth2client/oauth2client-1.4.11.ebuild37
-rw-r--r--dev-python/oauth2client/oauth2client-1.4.6.ebuild37
4 files changed, 84 insertions, 0 deletions
diff --git a/dev-python/oauth2client/Manifest b/dev-python/oauth2client/Manifest
new file mode 100644
index 000000000000..4b0332aa3a5e
--- /dev/null
+++ b/dev-python/oauth2client/Manifest
@@ -0,0 +1,2 @@
+DIST oauth2client-1.4.11.tar.gz 107844 SHA256 c7f4af0ae4ef7717fc596709e5c5d6ee5775f1fa2b2d69ccfaf0c7c42f2e6756 SHA512 bf06e5a1bb903f940d1e384a9213e13e9e815460a5d79ad24942fbf619d70b39392bc764b0867faea4557bfe031e8a6734639401d6d4ac6297517d840b5191d3 WHIRLPOOL fad31559f000ce7a3154e9fa458bc9731c7e4ef7a392e74e6888e6ee5b649a31284adb1b487fa57406a8ff30b37c9a1a840f0b1fb66bc2a9573cabea2375f2bc
+DIST oauth2client-1.4.6.tar.gz 95325 SHA256 d4376fc0f5543612c62cdee5ea68530bd9c8542891b3f4427d8bf9a1f5a134c8 SHA512 e75e6c535ca4e427f3a869fa7e600bf7544752a100f623cbbeb117d872a2361a60d1524fc2639521393a58dc6f684d9e1452980d6a5ffb6f4dbed516911cc4ca WHIRLPOOL acb26ef17115138a8932313cbbb8c9a802e2296d20343ab746123ad0ef8a38ea8587c10c45863b56b7b4d5b052675434236a050ae64c6c05546a42fd3cdc4f6b
diff --git a/dev-python/oauth2client/metadata.xml b/dev-python/oauth2client/metadata.xml
new file mode 100644
index 000000000000..b36b6dfa4390
--- /dev/null
+++ b/dev-python/oauth2client/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="github">google/oauth2client</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/oauth2client/oauth2client-1.4.11.ebuild b/dev-python/oauth2client/oauth2client-1.4.11.ebuild
new file mode 100644
index 000000000000..c13ae18e82ef
--- /dev/null
+++ b/dev-python/oauth2client/oauth2client-1.4.11.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy)
+
+inherit distutils-r1
+
+DESCRIPTION="Library for accessing resources protected by OAuth 2.0"
+HOMEPAGE="https://github.com/google/oauth2client"
+SRC_URI="https://github.com/google/oauth2client/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/httplib2-0.9.1[${PYTHON_USEDEP}]
+ ~dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
+ ~dev-python/pyasn1-modules-0.0.5[${PYTHON_USEDEP}]
+ ~dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
+ >=dev-python/six-1.6.1[${PYTHON_USEDEP}]
+ !<=dev-python/google-api-python-client-1.1[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+# Needs network
+RESTRICT=test
+
+python_test() {
+ nosetests || die
+}
diff --git a/dev-python/oauth2client/oauth2client-1.4.6.ebuild b/dev-python/oauth2client/oauth2client-1.4.6.ebuild
new file mode 100644
index 000000000000..7621c7e14e62
--- /dev/null
+++ b/dev-python/oauth2client/oauth2client-1.4.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for accessing resources protected by OAuth 2.0"
+HOMEPAGE="https://github.com/google/oauth2client"
+SRC_URI="https://github.com/google/oauth2client/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 arm x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/httplib2-0.8[${PYTHON_USEDEP}]
+ ~dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
+ ~dev-python/pyasn1-modules-0.0.5[${PYTHON_USEDEP}]
+ ~dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
+ >=dev-python/six-1.6.1[${PYTHON_USEDEP}]
+ !<=dev-python/google-api-python-client-1.1[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+# Needs network
+RESTRICT=test
+
+python_test() {
+ nosetests || die
+}