summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pychef
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pychef')
-rw-r--r--dev-python/pychef/Manifest2
-rw-r--r--dev-python/pychef/metadata.xml16
-rw-r--r--dev-python/pychef/pychef-0.2.1.ebuild27
-rw-r--r--dev-python/pychef/pychef-0.2.3.ebuild27
4 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/pychef/Manifest b/dev-python/pychef/Manifest
new file mode 100644
index 000000000000..ba5347643540
--- /dev/null
+++ b/dev-python/pychef/Manifest
@@ -0,0 +1,2 @@
+DIST PyChef-0.2.1.tar.gz 29251 SHA256 a74e922eb275a1ea26fc1e65eeb503a610f026f144d6537160f3f380d2108489 SHA512 8d591087c649b5b0d09d4f7b7b26cec56631742833ac7b53eaaa744bd3b42d290ec37df96bdb0ea17a9c824d091d4527458d83abcdf4b2c029f921dbda425220 WHIRLPOOL d271b8991061155b8195e6b90877423ac5363064e9257a1a238b2b3a4f2a389c6b7fa8923ae85ac3f4946fa78e493556ce3fd61945d8bc8f02daa8e0325e994c
+DIST PyChef-0.2.3.tar.gz 21082 SHA256 212df9a0887f7f0dfb420ecc33b554104db7222c1a1ef26e1362b3207a9260cd SHA512 e8e0f3045f23032d8fe3169e9ff66cb3ce78ac1a9910d35c7399eeb252b474668c11dde4205689608c073b95f380738bf34b47d32ee5d24edb61fe3fd1674790 WHIRLPOOL d3ea4dca96e111310ab2a8f1761d10e68b9bf8f6e7d1dc6e9787e1c4aec7e0d14fca56561fd9f5ec164f7544fad6ba896aed0830073dadb0d8ac169a085c2350
diff --git a/dev-python/pychef/metadata.xml b/dev-python/pychef/metadata.xml
new file mode 100644
index 000000000000..6e72a706ec1e
--- /dev/null
+++ b/dev-python/pychef/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ A Python API for interacting with a Chef server.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">PyChef</remote-id>
+ <remote-id type="github">coderanger/pychef</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pychef/pychef-0.2.1.ebuild b/dev-python/pychef/pychef-0.2.1.ebuild
new file mode 100644
index 000000000000..088d04107737
--- /dev/null
+++ b/dev-python/pychef/pychef-0.2.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Nova API"
+HOMEPAGE="https://github.com/coderanger/pychef"
+SRC_URI="mirror://pypi/P/PyChef/PyChef-${PV}.tar.gz"
+S="${WORKDIR}/PyChef-${PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/versiontools[${PYTHON_USEDEP}]
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+python_test() {
+ nosetests || die
+}
diff --git a/dev-python/pychef/pychef-0.2.3.ebuild b/dev-python/pychef/pychef-0.2.3.ebuild
new file mode 100644
index 000000000000..addbd074f9c8
--- /dev/null
+++ b/dev-python/pychef/pychef-0.2.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python API for interacting with a Chef server"
+HOMEPAGE="https://github.com/coderanger/pychef"
+SRC_URI="mirror://pypi/P/PyChef/PyChef-${PV}.tar.gz"
+S="${WORKDIR}/PyChef-${PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/versiontools[${PYTHON_USEDEP}]
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+python_test() {
+ nosetests || die
+}