summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-11 14:02:11 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-11 14:02:11 +0100
commitd4089efd7a0bfefedcc20d5d321ec72f7b9eae78 (patch)
tree5efa9c4239d69bcbb2628757aca55f4cc33c7a27 /dev-python/pylint
parentdev-python/dnspython: Drop old (diff)
downloadgentoo-d4089efd7a0bfefedcc20d5d321ec72f7b9eae78.tar.gz
gentoo-d4089efd7a0bfefedcc20d5d321ec72f7b9eae78.tar.bz2
gentoo-d4089efd7a0bfefedcc20d5d321ec72f7b9eae78.zip
dev-python/pylint: Version Bump
Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/Manifest1
-rw-r--r--dev-python/pylint/pylint-1.5.3.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/pylint/Manifest b/dev-python/pylint/Manifest
index e760a833e1c8..f3fe63d78133 100644
--- a/dev-python/pylint/Manifest
+++ b/dev-python/pylint/Manifest
@@ -2,3 +2,4 @@ DIST pylint-1.4.4.tar.gz 342461 SHA256 0561af4d6bd4fa9e8e02f3997fe93684f7187c57b
DIST pylint-1.4.5.tar.gz 342366 SHA256 cd6623bdd6e79b6b1e4c24672bdfa5923ce14541cf26fecd2bbc56845d136086 SHA512 530cdf53c411afc2b96d1716c5f9effa7b6406f9957c2b5183f651f47e458c28692e183f905a321adeb4919bd0ec68a4148fb171294ad08dfb5b87d37668849f WHIRLPOOL d4ccb18f42ab9b270c949ce145ec22a0f0f0f065f97e2f9fadd29b5503b348bee7ecf1321055b91dca3a9690946c238b09221521612c68f64d42d6170d92d7b0
DIST pylint-1.5.1.tar.gz 419684 SHA256 044e9f03eee51ac1cb05f094af6ccc2a2195c558d233819c22527062dff46225 SHA512 4ea88259ad9b63f02220a32365a446417db751809d24bef5f5a3c4ab4ec62942c02b46acf4dd60f2f3ac849789e306db03bd958d3d181d4c42860efa551927e3 WHIRLPOOL 1a35194d53bb77695164b356abeada82597ca7f228d2d8a9c43ac9880727136d829e135c2fbd85e41ddcd826099cb3d77d42d8b5b55e8952da0ab9f183e4d244
DIST pylint-1.5.2.tar.gz 419023 SHA256 983bec35e10b0c5f0ec33c03629fe832642c46b76a43edce37a2e8d2708d2179 SHA512 27c4c28ff2aa80fba95033c84af7732365dcf8351cd0caee0205d28100106e194071d51d17d133ccf5ea95a6165896c43851dd397e02676d12720f426cc52afc WHIRLPOOL 16eebbd15f1af4b1932e26419ecb607604fc4b25973c54c444f98be46fd95b374bb0ddc8e5bd3880a272766426f241d6a694433ec9db8d44b559ecda7d231321
+DIST pylint-1.5.3.tar.gz 422412 SHA256 c0a5d4123873455292d1e360cceb1ee8527edb74783ddb4882cf22a2de86be76 SHA512 1321211b04a85fe6961858e6b6e2c40429a4a5713784f4bc7507f87063e0877d0299789650915f2c81f8c4b6df6ff5bc566e79267afa4b070763c28cb7643891 WHIRLPOOL aaeef16064e742a6f39a77745ec9f2b97038f88f14b4dedff83916bb3d782d01456f659d12d16d8c45f32c6ebf45334d40ad1c18356b7cabfaad165cd83b3447
diff --git a/dev-python/pylint/pylint-1.5.3.ebuild b/dev-python/pylint/pylint-1.5.3.ebuild
new file mode 100644
index 000000000000..355d5cfb4634
--- /dev/null
+++ b/dev-python/pylint/pylint-1.5.3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} pypy )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Python code static checker"
+HOMEPAGE="
+ http://www.logilab.org/project/pylint
+ https://pypi.python.org/pypi/pylint
+ https://github.com/pycqa/pylint"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="doc examples test"
+
+RDEPEND="
+ >=dev-python/astroid-1.4.1[${PYTHON_USEDEP}]
+ <dev-python/astroid-1.5.0[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( ${RDEPEND} )"
+
+RESTRICT="test" # multiple failures
+
+# Usual. Requ'd for impl specific failures in test phase
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile_all() {
+ # selection of straight html triggers a trivial annoying bug, we skirt it
+ use doc && PYTHONPATH="${S}" emake -e -C doc singlehtml
+}
+
+python_test() {
+ ${PYTHON} \
+ -m unittest discover \
+ -s pylint/test/ -p "*test_*".py \
+ --verbose || die
+}
+
+python_install_all() {
+ doman man/{pylint,pyreverse}.1
+ use examples && local EXAMPLES=( examples/. )
+ use doc && local HTML_DOCS=( doc/_build/singlehtml/. )
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ # Optional dependency on "tk" USE flag would break support for Jython.
+ optfeature "pylint-gui script requires dev-lang/python with \"tk\" USE flag enabled." dev-lang/python[tk]
+}